Bug 486623 - When changeing resolution many times, gnome-panel locks up, using 100% CPU
When changeing resolution many times, gnome-panel locks up, using 100% CPU
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-panel (Show other bugs)
4.8
All Linux
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 13:05 EST by ritz
Modified: 2010-10-23 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:37:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (911 bytes, patch)
2009-02-20 13:05 EST, ritz
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 160097 None None None Never
Red Hat Product Errata RHBA-2009:1033 normal SHIPPED_LIVE gnome-panel bug fix update 2009-05-18 11:39:25 EDT

  None (edit)
Description ritz 2009-02-20 13:05:50 EST
Created attachment 332739 [details]
patch based on upstream code

Description of problem:
If you change the resolution using the "Screen resolution" utility or xrandr
many times, gnome-panel locks up, using 100%cpu

Version-Release number of selected component (if applicable):
gnome-panel-2.8.1-9.el4

How reproducible:
always

Steps to Reproduce:
1. Keep changing screen resolution
  
Actual results:
gnome-panel locks up

Expected results:
no lock up

Additional info:
Upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=160097

Patch :
http://svn.gnome.org/viewvc/gnome-panel/trunk/gnome-panel/panel-multiscreen.c?r1=7807&r2=8736
Comment 9 RHEL Product and Program Management 2009-03-19 10:52:10 EDT
Since RHEL 4.8 External Beta has begun, and this bugzilla remains 
unresolved, it has been rejected as it is not proposed as exception or 
blocker.
Comment 17 errata-xmlrpc 2009-05-18 16:37:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1033.html

Note You need to log in before you can comment on or make changes to this bug.