Bug 486665 - Nemiver must be rebuilt against ghex 2.24
Nemiver must be rebuilt against ghex 2.24
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nemiver (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 17:04 EST by Dodji Seketeli
Modified: 2009-02-25 11:25 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.4-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 18:28:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updates to Nemiver in rawhide (1.42 KB, patch)
2009-02-20 17:04 EST, Dodji Seketeli
no flags Details | Diff
The patchlet to make nemiver compile with gcc in rawhide :) (344 bytes, patch)
2009-02-20 17:12 EST, Dodji Seketeli
no flags Details | Diff

  None (edit)
Description Dodji Seketeli 2009-02-20 17:04:18 EST
Created attachment 332767 [details]
Updates to Nemiver in rawhide

Nemiver 0.6.4 was suffering some random crashes at startup: http://bugzilla.gnome.org/show_bug.cgi?id=571099.

It appears it's ghex that is at fault. Ghex upstream pushed a new release fixing that. Unfortunately, Nemiver must be rebuilt against the new ghex for the fix to take effect.

I pushed a new ghex 2.24 to rawhide and to F-10. I pushed a patched ghex 2.22 to F-9, with only the backported fix of the crash.

It appeared that I was obliged to patch the Nemiver package in rawhide to make it compile with the new gcc 4.3.3 in rawhide. I am not even talking about gcc 4.4 yet :)

I can't yet rebuild nemiver in F-10 (because the new ghex hasn't hit F-10 yet) and I am not sure yet if nemiver in F-9 has the problem.

In any case, please find below the changes I am proposing to the nemiver.spec of rawhide, as well as the patchlet I did to make Nemiver compile with the gcc of rawhide.
Comment 1 Dodji Seketeli 2009-02-20 17:12:24 EST
Created attachment 332769 [details]
The patchlet to make nemiver compile with gcc in rawhide :)
Comment 2 Dodji Seketeli 2009-02-20 18:24:13 EST
The koji build for that spec + patch is http://koji.fedoraproject.org/koji/taskinfo?taskID=1143265
Comment 3 Peter Gordon 2009-02-24 00:32:21 EST
Looks good to me; feel free to commit. :)
Comment 4 Fedora Update System 2009-02-24 17:18:29 EST
nemiver-0.6.4-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nemiver-0.6.4-2.fc10
Comment 5 Fedora Update System 2009-02-25 11:25:17 EST
nemiver-0.6.4-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.