Bug 486685 - sagator from updates-testing repository fails to update on F10 x86_64
sagator from updates-testing repository fails to update on F10 x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sagator (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Jan ONDREJ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 19:18 EST by stanl
Modified: 2009-02-21 14:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 13:28:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stanl 2009-02-20 19:18:23 EST
Description of problem:  There appears to be a problem in the sagator packages in updates-testing.

Version-Release number of selected component (if applicable):
 sagator-core         noarch      1.1.1-1.fc10       updates-testing      377 k
 sagator-selinux      noarch      1.1.1-1.fc10       updates-testing       11 k
 sagator-webq       noarch       1.1.1-1.fc10       updates-testing        28 k


How reproducible:  Every time.


Steps to Reproduce:
1. run yum update --enablerepo=updates-testing sagator-core
2.
3.
  
Actual results:
Running Transaction

  Installing     : sagator-core                                             1/3 
error: unpacking of archive failed on file /usr/share/sagator: cpio: lsetfilecon

  Updating       : sagator-selinux                                          2/3 
error: unpacking of archive failed on file /usr/share/sagator/selinux: cpio: lsetfilecon
Warning: scriptlet or other non-fatal errors occurred during transaction.
Transaction time: 2.973

Running Transaction

  Installing     : sagator-core                                             1/3 
error: unpacking of archive failed on file /usr/share/sagator: cpio: lsetfilecon

  Updating       : sagator-webq                                             2/3 
error: unpacking of archive failed on file /usr/share/sagator/srv/web: cpio: lsetfilecon
Warning: scriptlet or other non-fatal errors occurred during transaction.



Expected results:
successful update

Additional info:

================================================================================
 Package              Arch        Version            Repository            Size
================================================================================
Updating:
 sagator-selinux      noarch      1.1.1-1.fc10       updates-testing       11 k
Installing for dependencies:
 sagator-core         noarch      1.1.1-1.fc10       updates-testing      377 k

================================================================================
 Package            Arch         Version            Repository             Size
================================================================================
Updating:
 sagator-webq       noarch       1.1.1-1.fc10       updates-testing        28 k
Installing for dependencies:
 sagator-core       noarch       1.1.1-1.fc10       updates-testing       377 k
Comment 1 Jan ONDREJ 2009-02-21 02:25:09 EST
Can you try to update with selinux disabled? I think it has something with selinux, which can't be fixed in this release.

Try this:

state=`getenforce`
setenforce 0
yum update --enablerepo=updates-testing sagator-core
setenforce $state
Comment 2 Jan ONDREJ 2009-02-21 03:16:16 EST
Which version of sagator you have before update? (rpm -qa sagator\*)

There is no sagator-core in current fedora-10-stable. When trying to reproduce this on my machine (it's only a i386, but this should be similar for x86_64, because sagator is arch independent):

[root@localhost ~]# yum upgrade --enablerepo=updates-testing sagator-core
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * fedora: ftp.upjs.sk
 * updates-testing: ftp.upjs.sk
 * updates: ftp.upjs.sk
Setting up Upgrade Process
No Match for argument: sagator-core
Package(s) sagator-core available, but not installed.
No Packages marked for Update
[root@localhost ~]# 

Curious, that your errors are only on directories. May be it has something with fact, that these directories was not owned by sagator-1.1.0 and this bug has been fixed by sagator-1.1.1. I think I can do nothing with this error, because it's an error of sagator-1.1.0 and not this new version.

If you can help me to reproduce this bug on my machine, I can do more tests.
Comment 3 stanl 2009-02-21 11:22:24 EST
You are right about the command.  The two commands that actually ran:
yum -y update --enablerepo=updates-testing sagator-selinux.noarch 
yum -y update --enablerepo=updates-testing sagator-webq.noarch 

The sagator-core was pulled in as a dependency by yum.

Here is what is currently installed:

$ rpm -qa | grep -i sagator
sagator-selinux-1.1.1-0.beta1.fc10.noarch
sagator-1.1.1-1.fc10.noarch
sagator-webq-1.1.1-0.beta1.fc10.noarch

I haven't yet tried your workaround.  I'll update the ticket with those results later.

Thanks for your response.
Comment 4 stanl 2009-02-21 11:38:33 EST
Putting selinux in permissive mode allowed the transaction to succeed.

Dependency Installed:
  sagator-core.noarch 0:1.1.1-1.fc10

Updated:
  sagator-selinux.noarch 0:1.1.1-1.fc10                        sagator-webq.noarch 0:1.1.1-1.fc10

After the update there are the following packages installed:

$ rpm -qa | grep -i sagator
sagator-core-1.1.1-1.fc10.noarch
sagator-selinux-1.1.1-1.fc10.noarch
sagator-1.1.1-1.fc10.noarch
sagator-webq-1.1.1-1.fc10.noarch

There were *many* selinux errors indicated by SETroubleshooter during this update.
Comment 5 Jan ONDREJ 2009-02-21 13:28:52 EST
Well. I think this problems is caused by sagator-1.1.0 and already fixed in sagator-1.1.1, but I can't fix this before update, so this will fail if somebody has selinux enabled during update.

It looks, that selinux checks ownership of directories and directories, which are not owned by a package (they was missed in sagator<=1.1.0) are not permitted.
I think it's an feature of selinux policy and not a bug.

Can I close this bug as "CANTFIX"?
Comment 6 stanl 2009-02-21 13:41:38 EST
Fine by me.  What will happen when the updates get pushed to updates from updates-testing?  Will everyone who has selinux in enforcing mode then fail to update unless they turn enforcing off?  Seems you should ask someone for a workaround (Dan Walsh?) and rerelease with the fix.

But it is up to you.
Comment 7 Jan ONDREJ 2009-02-21 13:45:15 EST
I think he also can't do anything with this.

What happened after your fist update? sagator-1.1.1 was installed partially or not installed?

If installed partially, then may be only directory selinux contexts was not set properly, which is not critical.
Comment 8 stanl 2009-02-21 14:24:15 EST
I think it partially updated sagator-1.1.1.  

So that being the case, let's let it go. :-)

Note You need to log in before you can comment on or make changes to this bug.