Bug 486688 - Missing epoch in requires for wpa_supplicant in the NetworkManager package
Missing epoch in requires for wpa_supplicant in the NetworkManager package
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 19:54 EST by Phil Perry
Modified: 2009-09-02 07:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The NetworkManager package requires wpa_supplicant, but previously omitted the Epoch term for the wpa_supplicant package. Consequently, installing NetworkManager did not ensure that a suitable version of wpa_supplicant was installed on the system. Now, the NetworkManager package specifies the epoch for the version of wpa_supplicant that it requires.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:54:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3399 None None None Never

  None (edit)
Description Phil Perry 2009-02-20 19:54:21 EST
Description of problem:

'yum update NetworkManager' fails to pull in updated wpa_supplicant as a dependency when updating from 5.2 to 5.3.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-3.el5

How reproducible:

Always

Steps to Reproduce:
1. From 5.2, do 'yum update NetworkManager'
2.
3.
  
Actual results:

wpa_supplicant does not get updated

Expected results:

wpa_supplicant should also get updated as a dependency

Additional info:

In the spec file of NetworkManager-0.7.0-3.el5

Requires: wpa_supplicant >= 0.5.7-21

has the epoch missing. It should be:

Requires: wpa_supplicant >= 1:0.5.7-21
Comment 2 Ruediger Landmann 2009-05-24 22:13:28 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The NetworkManager package requires wpa_supplicant, but previously omitted the Epoch term for the wpa_supplicant package. Consequently, installing NetworkManager did not ensure that a suitable version of wpa_supplicant was installed on the system. Now, the NetworkManager package specifies the epoch for the version of wpa_supplicant that it requires.
Comment 3 Zack Cerza 2009-06-15 13:07:59 EDT
Verified on NetworkManager-0.7.0-7.el5.
Comment 5 errata-xmlrpc 2009-09-02 07:54:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1389.html

Note You need to log in before you can comment on or make changes to this bug.