Bug 486735 - Install guide RHEL5 version 3 bugs
Install guide RHEL5 version 3 bugs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
desktop-bugs@redhat.com
: Documentation
Depends On:
Blocks: 553509 553510
  Show dependency treegraph
 
Reported: 2009-02-21 11:01 EST by Need Real Name
Modified: 2010-06-01 16:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 553509 553510 (view as bug list)
Environment:
Last Closed: 2010-06-01 16:25:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-02-21 11:01:24 EST
Bugs specific to this documentation:

1. The installer allows GRUB to be installed on a software RAID-1 partition, but not RAID-0 because this in unsafe. Your documentation mentions that actually RAID-1 is not safe either, a failure of one disk may make the system unbootable.
a) Link to http://www.dur.ac.uk/a.d.stribblehill/mirrored_grub.html is broken
b) More information on this problem is needed, why is RAID-1 not more safe?

2. Broken link to rhlinux.redhat.com/anaconda

3. The echo command on page 312 will fail since it contains an exclamation mark

4. On page 322, tjeshutdown command should be split across two lines.
On page 328 same for the chkconfig command.

5. Page 328, the version string is confusing. Is this version 3 (as in the guide version), or a minor version of RHEL, in which case it seems wrong.

General documentation bugs:
1. page xvi bugzilla address is old. This error exists in all documentation.
2. Code samples in grey boxes are missing newlines all over the place. See bug 4 above. This error exists in the deployment guide, the install guide, and probably all FOP produced docs.
Comment 1 Need Real Name 2009-03-18 17:33:16 EDT
Don't you want bug reports any more? :)
Comment 2 Need Real Name 2009-11-08 10:08:22 EST
Hi,

Do you want corrections to the documentation your enterprise customers use, or don't you want corrections?

If you do want them I suggest actually responding to the people that take to correct it for you.
Comment 3 Need Real Name 2010-01-01 12:13:29 EST
Changing to false severity to get attention.

Free documentation corrections people!
Comment 4 Need Real Name 2010-01-06 16:16:40 EST
@John Ha: please can you make this bug public.
Comment 5 Subhendu Ghosh 2010-01-06 16:54:14 EST
Wrong product assignment. Moving to Red Hat Enterprise Linux
Comment 6 RHEL Product and Program Management 2010-01-06 16:58:48 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Ruediger Landmann 2010-01-11 00:04:41 EST
Hi and thanks for the extensive feedback. Sorry that it took so long for this bug to find its way to the Installation Guide.

> 1. The installer allows GRUB to be installed on a software RAID-1 partition,
> but not RAID-0 because this in unsafe. Your documentation mentions that
> actually RAID-1 is not safe either, a failure of one disk may make the system
> unbootable.
> a) Link to http://www.dur.ac.uk/a.d.stribblehill/mirrored_grub.html is broken

[Section 9.3]

We now have a Red Hat Knowledgebase article on this issue; so I'm linking there instead: http://kbase.redhat.com/faq/docs/DOC-7095

> b) More information on this problem is needed, why is RAID-1 not more safe?

Sorry, I don't understand what you're asking for here. Could you re-word the question for me please?

> 2. Broken link to rhlinux.redhat.com/anaconda

[Section 6.3.7]

Fixed -- the new anaconda homepage is http://fedoraproject.org/wiki/Anaconda

> 3. The echo command on page 312 will fail since it contains an exclamation mark

[Section 31.11 and 31.11.1]

Fixed.

> 4. On page 322, tjeshutdown command should be split across two lines.
> On page 328 same for the chkconfig command.

[Section 32.5 and 33.4.1]

Fixed.

> 5. Page 328, the version string is confusing. Is this version 3 (as in the
> guide version), or a minor version of RHEL, in which case it seems wrong.

[Appendix A]

I've added a note that the revision number does indeed refer to the edition of the manual, not the version of Red Hat Enterprise Linux.

> General documentation bugs:
> 1. page xvi bugzilla address is old. This error exists in all documentation.

[Section 4.1]

This is a bug in Publican, our XML publication tool. I've filed Bug 553528 about this issue and CCed you on it.

> 2. Code samples in grey boxes are missing newlines all over the place. See bug
> 4 above. This error exists in the deployment guide, the install guide, and
> probably all FOP produced docs.    

I found another four in the Installation Guide (sections 6.33, 16.6, 27.2, and 34.5) and corrected them. If you're aware of any that I've missed, please let me know. If you've found similar flaws in the Deployment Guide, please open a bug against it and let the maintainer know.

Thanks again for all the valuable feedback -- I'm setting this to NEEDINFO now so I can see what more needs to be done to fix point 1b of your report.

All of the changes described above will become visible the next time that we republish the guide (certainly with the release of Red Hat Enterprise Linux 5.5, if not sooner).

Cheers

Ruediger
Comment 8 Need Real Name 2010-01-11 02:00:02 EST
(In reply to comment #7)
> > b) More information on this problem is needed, why is RAID-1 not more safe?
> 
> Sorry, I don't understand what you're asking for here. Could you re-word the
> question for me please?

Just below the bad link:
"If GRUB is installed on a RAID 1 array, the system may become unbootable in the event of disk failure. An unsupported workaround is provided online at the following URL:"
 -- https://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-grub-installing.html

It seems the installer supports RAID-1 for grub, but it's not safe, which is an odd situation. If the install guide could clarify what is not unsafe about it, then the sysadmin can make the decision whether the risk is worth it and/or applies in their environment.
Comment 9 Ruediger Landmann 2010-01-12 00:22:24 EST
> It seems the installer supports RAID-1 for grub, but it's not safe, which is an
> odd situation. If the install guide could clarify what is not unsafe about it,
> then the sysadmin can make the decision whether the risk is worth it and/or
> applies in their environment.    

OK -- I get it now. Thanks! I hope this explains the situation a little more clearly:

GRUB cannot construct a software RAID. Therefore, the /boot directory must reside on a single, specific disk partition. The /boot directory cannot be striped across multiple disks, as in a level 0 RAID. To use a level 0 RAID on your system, place /boot on a separate partition outside the RAID.

Similarly, because the /boot directory must reside on a single, specific disk partition, GRUB cannot boot the system if the disk holding that partition fails or is removed from the system. This is true even if the disk is mirrored in a level 1 RAID. The following Red Hat Knowledgebase article describes how to make the system bootable from another disk in the mirrored set: http://kbase.redhat.com/faq/docs/DOC-7095

Note that these issues apply only to RAID that is implemented in software, where the individual disks that make up the array are still visible as individual disks on the system. These issues do not apply to hardware RAID where multiple disks are represented as a single device.

------------------------------------------------------------------------
r25315 | rlandman@REDHAT.COM | 2010-01-12 15:18:25 +1000 (Tue, 12 Jan 2010) | 1 line

Explain RAID issues -- BZ#486735

Note You need to log in before you can comment on or make changes to this bug.