Bug 486742 - satellite install, selinux denials osa-dispatcher
satellite install, selinux denials osa-dispatcher
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
na
: Reopened
Depends On:
Blocks: 457079
  Show dependency treegraph
 
Reported: 2009-02-21 11:35 EST by wes hayutin
Modified: 2009-08-06 09:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 09:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-02-21 11:35:13 EST
Description of problem:

satellite install, selinux denials osa-dispatcher

Satellite-5.3.0-RHEL5-re20090220.1-i386-embedded-oracle.iso

clear audit log
install latest satellite iso
check audit log


type=AVC msg=audit(1235187502.664:399): avc:  denied  { read write } for  pid=9614 comm="osa-dispatcher" path="socket:[7018]" dev=sockfs ino=7018 scontext=root:system_r:osa
_dispatcher_t:s0 tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
type=AVC msg=audit(1235187502.664:399): avc:  denied  { read write } for  pid=9614 comm="osa-dispatcher" path="socket:[7018]" dev=sockfs ino=7018 scontext=root:system_r:osa
_dispatcher_t:s0 tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
type=AVC msg=audit(1235187502.664:399): avc:  denied  { read write } for  pid=9614 comm="osa-dispatcher" path="socket:[7020]" dev=sockfs ino=7020 scontext=root:system_r:osa
_dispatcher_t:s0 tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
Comment 1 wes hayutin 2009-02-21 11:37:30 EST

*** This bug has been marked as a duplicate of bug 484653 ***
Comment 2 Jan Pazdziora 2009-02-24 06:17:11 EST
The AVC denials are completely different. Reopening.
Comment 3 Jan Pazdziora 2009-02-24 06:18:37 EST
What did you do after that installation? After the installer said

* Deploying configuration files.
* Update configuration in database.
* Setting up Cobbler..
* Restarting services.
Installation complete.
Visit https://your-satellite.redhat.com to create the RHN Satellite
administrator account.

what other steps did you make?

Could it be that you are not running the installer on a terminal but from some automation thing, and it's that thing which causes the problem?
Comment 4 Jan Pazdziora 2009-02-24 06:30:39 EST
Generally, these look like leaked descriptors from whatever automation tool you are using.

Please provide info about how exactly you run those installations.
Comment 5 wes hayutin 2009-02-24 21:36:52 EST
Jan and I chatted.. the differences we are seeing may be caused by running the installer in a "screen" session.
Comment 6 Jan Pazdziora 2009-02-25 03:04:59 EST
Wes confirmed that the installation was run under screen and that re-running the installation without screen does not generate the AVC denials. So currently it looks like leaked file descriptor in screen.
Comment 7 wes hayutin 2009-02-25 13:58:30 EST
running w/ the correct version of screen did NOT produce this error..
I think we can close this.
Comment 8 wes hayutin 2009-03-16 09:08:32 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.