Bug 486743 - satellite install, selinux denials httpd
satellite install, selinux denials httpd
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
na
:
Depends On:
Blocks: 457079
  Show dependency treegraph
 
Reported: 2009-02-21 11:40 EST by wes hayutin
Modified: 2009-03-16 10:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 10:01:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-02-21 11:40:47 EST
Description of problem:
satellite install, selinux denials httpd 

Satellite-5.3.0-RHEL5-re20090220.1-i386-embedded-oracle.iso

clear audit log
install latest satellite iso
check audit log

ype=AVC msg=audit(1235187505.248:404): avc:  denied  { read write } for  pid=10165 comm="httpd" path="socket:[7018]" dev=sockfs ino=7018 scontext=root:system_r:httpd_t:s0 
tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
type=AVC msg=audit(1235187505.248:404): avc:  denied  { read write } for  pid=10165 comm="httpd" path="socket:[7018]" dev=sockfs ino=7018 scontext=root:system_r:httpd_t:s0 
tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
type=AVC msg=audit(1235187505.248:404): avc:  denied  { read write } for  pid=10165 comm="httpd" path="socket:[7020]" dev=sockfs ino=7020 scontext=root:system_r:httpd_t:s0 
tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
Comment 1 Jan Pazdziora 2009-02-24 06:12:52 EST
What did you do after that installation? After the installer said

* Deploying configuration files.
* Update configuration in database.
* Setting up Cobbler..
* Restarting services.
Installation complete.
Visit https://your-satellite.redhat.com to create the RHN Satellite
administrator account.

what other steps did you make?
Comment 2 Jan Pazdziora 2009-02-24 06:30:40 EST
Generally, these look like leaked descriptors from whatever automation tool you are using.

Please provide info about how exactly you run those installations.
Comment 3 wes hayutin 2009-02-24 21:38:14 EST
Again, we spoke about screen.  If access to the script is necessary..
please see $SVNDIR/qa/automation/sat-install-script/install-sat.sh
Comment 4 Jan Pazdziora 2009-02-25 03:05:00 EST
Wes confirmed that the installation was run under screen and that re-running the installation without screen does not generate the AVC denials. So currently it looks like leaked file descriptor in screen.
Comment 5 Jan Pazdziora 2009-03-16 09:59:40 EDT
The same problem as bug 486742: screen possibly leaking descriptors was leading to AVC denials. Closing as NOTABUG as it's not strictly speaking a duplicate -- the cause was the same but the symptoms showed in different programs.

Note You need to log in before you can comment on or make changes to this bug.