Bug 486744 - yum fails with dependency which is fulfilled (F11/Alpha)
yum fails with dependency which is fulfilled (F11/Alpha)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 12:02 EST by Andrew Hecox
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 14:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Hecox 2009-02-21 12:02:25 EST
latest pull from rawhide blows up with:

gnome-phone-manager-0.60-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libgnomebt.so.0 is needed by package gnome-phone-manager-0.60-3.fc10.i386 (installed)
gnome-phone-manager-0.60-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libbtctl.so.4 is needed by package gnome-phone-manager-0.60-3.fc10.i386 (installed)
--> Running transaction check
--> Processing Dependency: libgnomebt.so.0 for package: gnome-phone-manager
---> Package kernel.i586 0:2.6.29-0.112.rc4.git3.fc11 set to be erased
---> Package kernel-devel.i586 0:2.6.29-0.112.rc4.git3.fc11 set to be erased
--> Processing Dependency: libbtctl.so.4 for package: gnome-phone-manager
--> Finished Dependency Resolution
gnome-phone-manager-0.60-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libgnomebt.so.0 is needed by package gnome-phone-manager-0.60-3.fc10.i386 (installed)
gnome-phone-manager-0.60-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libbtctl.so.4 is needed by package gnome-phone-manager-0.60-3.fc10.i386 (installed)
Error: Missing Dependency: libgnomebt.so.0 is needed by package gnome-phone-manager-0.60-3.fc10.i386 (installed)
Error: Missing Dependency: libbtctl.so.4 is needed by package gnome-phone-manager-0.60-3.fc10.i386 (installed)

libbtctl.so.4 is installed, so it's not clear if this is a yum or gnome-phone-manager issue.
Comment 1 seth vidal 2009-02-27 14:31:06 EST
Can you print the rest of the transaction so we know what was trying to be done?
Comment 2 Andrew Hecox 2009-02-27 14:46:20 EST
yes, next rawhide kernel update I'll put in the full log.
Comment 3 Andrew Hecox 2009-02-27 14:47:13 EST
oh, sorry, wrong yum ticket. I can provide this info Monday.
Comment 4 seth vidal 2009-03-03 15:29:44 EST
ping!
Comment 5 seth vidal 2009-03-12 12:34:47 EDT
Andrew,
 ping?Is this fixed?
Comment 6 Andrew Hecox 2009-03-12 13:08:58 EDT
doh. sorry. 

yes -- I think it's package specific, I can't recreate the original failure now though, so that package must be cleaned up.

One question though: when will a local provide fail to satisfy the yum transaction? When the providing rpm is being obsoleted by another package in the transaction?

If that's the case, it might be easier to troubleshoot if something like:

 libfoo.so.4 is needed by package foo, which is available locally but set to be obsoleted by package foo-bar

Anyway, feel free to close as RAWHIDE or NOTABUG.

Thanks.
Comment 7 seth vidal 2009-03-12 14:41:11 EDT
I think in one case there may have been a legit packaging problem.

coupled with an error in yum which has been fixed.

I'm going to close this w/rawhide.

thanks

Note You need to log in before you can comment on or make changes to this bug.