Bug 486765 - Video failure with recent Rawhide kernels on Intel chipset
Video failure with recent Rawhide kernels on Intel chipset
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: yunus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 18:20 EST by Adam Huffman
Modified: 2009-03-08 13:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 13:50:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (31.02 KB, text/plain)
2009-02-21 18:24 EST, Adam Huffman
no flags Details
/var/log/messages beginning with boot to a kernel with this error (205.30 KB, text/plain)
2009-02-21 18:33 EST, Adam Huffman
no flags Details
dmesg I got before the system became unresponsive (47.94 KB, text/plain)
2009-02-22 09:52 EST, yunus
no flags Details

  None (edit)
Description Adam Huffman 2009-02-21 18:20:29 EST
Description of problem:
When booting to the Rawhide kernels after 2.6.29-0.119.rc5.fc11, video doesn't work properly on my Vaio SZ3 with the Intel 945GM chipset.  During booting the Plymouth progress bar doesn't appear, in fact there's just a blank screen.  When gdm is supposed to appear, the screen just flashes rapidly in blue.  Switching to the console doesn't work, so I have to reboot using Alt-SysRq.  This happens with both the 131 and 137 kernels.

Version-Release number of selected component (if applicable):
kernel-2.6.29-0.137.rc5.git4.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Huffman 2009-02-21 18:23:37 EST
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
07:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036 PCI-E Fast Ethernet Controller (rev 15)
09:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
09:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
09:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
Comment 2 Adam Huffman 2009-02-21 18:24:35 EST
Created attachment 332833 [details]
Xorg log file
Comment 3 Adam Huffman 2009-02-21 18:33:15 EST
Created attachment 332834 [details]
/var/log/messages beginning with boot to a kernel with this error
Comment 4 yunus 2009-02-22 09:52:12 EST
Created attachment 332857 [details]
dmesg I got before the system became unresponsive
Comment 5 yunus 2009-02-22 09:54:38 EST
I think I also have the same Intel 945GM chipset.

Below kernel versions also did not work on my Acer Laptop:
  kernel-2.6.29-0.124.rc5.fc11.x86_64
  kernel-2.6.29-0.137.rc5.git4.fc11.x86_64
  kernel-2.6.29-0.134.rc5.git2.fc11.x86_64
I was lucky I could boot and login to gnome session with those kernels. After using my system about 10 minutes, my system would become unresponsive enough and HDD led would light continuously.

I always found below message (I got it from dmesg) before my system became unresponsive enough (almost freeze)
<message>

=====================================
[ BUG: bad unlock balance detected! ]
-------------------------------------
Xorg/2794 is trying to release lock (&dev->struct_mutex) at:
[<ffffffff81392ff6>] mutex_unlock+0xe/0x10
but there are no more locks to release!

other info that might help us debug this:
1 lock held by Xorg/2794:
 #0:  (&dev->mode_config.mutex){--..}, at: [<ffffffffa001e562>] drm_mode_cursor_ioctl+0x71/0x15a [drm]

stack backtrace:
Pid: 2794, comm: Xorg Not tainted 2.6.29-0.137.rc5.git4.fc11.x86_64 #1
Call Trace:
 [<ffffffff81392ff6>] ? mutex_unlock+0xe/0x10
 [<ffffffff81070624>] print_unlock_inbalance_bug+0xd6/0xe1
 [<ffffffff810706de>] lock_release_non_nested+0xaf/0x1e9
 [<ffffffff81054c88>] ? run_timer_softirq+0x4c/0x1fd
 [<ffffffff8101398f>] ? do_softirq+0xa3/0xb9
 [<ffffffff81392ff6>] ? mutex_unlock+0xe/0x10
 [<ffffffff81070975>] lock_release+0x15d/0x189
 [<ffffffff81392f74>] __mutex_unlock_slowpath+0xc7/0x13b
 [<ffffffff81392ff6>] mutex_unlock+0xe/0x10
 [<ffffffffa0056dcb>] intel_crtc_cursor_set+0x23e/0x27e [i915]
 [<ffffffff81392ff6>] ? mutex_unlock+0xe/0x10
 [<ffffffffa001e4f1>] ? drm_mode_cursor_ioctl+0x0/0x15a [drm]
 [<ffffffffa001e5f3>] drm_mode_cursor_ioctl+0x102/0x15a [drm]
 [<ffffffffa0012e5a>] drm_ioctl+0x1fe/0x297 [drm]
 [<ffffffff810ee5e8>] vfs_ioctl+0x6f/0x87
 [<ffffffff810eea6b>] do_vfs_ioctl+0x46b/0x4ac
 [<ffffffff810eeb02>] sys_ioctl+0x56/0x79
 [<ffffffff8101133a>] system_call_fastpath+0x16/0x1b

.....

[drm:i915_gem_phys_pwrite] *ERROR* obj_addr ffff8800514a0000, 16384
[drm:i915_gem_phys_pwrite] *ERROR* obj_addr ffff8800514a0000, 16384

......

</message>

Last known kernel that works is kernel-2.6.29-0.119.rc5.fc11.x86_64. Though it often produces kerneloops.

My smolt profile:
http://www.smolts.org/client/show/pub_b1a5c778-2ca6-445b-9e2a-0645c1fe0a6f (public)
Comment 6 yunus 2009-03-08 12:33:46 EDT
Hi Adam,

Have you tried kernel-2.6.29-0.207.rc7.fc11.x86_64? (http://koji.fedoraproject.org/koji/buildinfo?buildID=92792)

It works for me now after applying full update and installing this kernel. I wonder know whether it will also work for you.
Comment 7 Adam Huffman 2009-03-08 13:22:03 EDT
Yes, it is working much better now - I'm running that kernel.
Comment 8 yunus 2009-03-08 13:50:30 EDT
The back ground of my screen is ugly I think this is caused by the low resolution. But at least it works now

When IntelKMS feature (http://fedoraproject.org/wiki/Features/IntelKMS) is complete, I believe it will benefit us with Intel chipset.

Adam, thank you for filing this bug. Since it has been worked for you (and me) I close this bug but if you think it should be open for another purposes, you may reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.