Bug 486781 - gnome-gmail-notifier doesn't boot on 64-bit
gnome-gmail-notifier doesn't boot on 64-bit
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-gmail-notifier (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Ian Weller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 22:29 EST by Sam Stuewe
Modified: 2009-03-22 23:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-22 23:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Stuewe 2009-02-21 22:29:51 EST
Description of problem:
See summary

Version-Release number of selected component (if applicable):
gnome-gmail-notifier-0.9.4-3.fc10.x86_64

How reproducible:
All the time

Steps to Reproduce:
1. 'gnome-gmail-notifier' in terminal
  
Actual results:
gnome-gmail-notifier: pthread_mutex_lock.c:87: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.

Expected results:
boots gnome-gmail-notifier
Comment 1 lexual 2009-02-26 07:50:57 EST
gnome-gmail-notifier-0.9.4-3.fc10.i386

Confirming that bug doesn't occur with x86.
Comment 2 Ian Weller 2009-03-08 18:18:53 EDT
bug posted upstream, but upstream is kinda non-responsive :(

http://code.google.com/p/gnome-gmail-notifier/issues/detail?id=35
Comment 3 Nick Moore 2009-03-20 11:55:04 EDT
Unfortunately the notifier seems to be running fine on my 64-bit Ubuntu install, so I guess there must be something specific to Fedora going wrong.

Could I ask you to install gdb and run the following: `gdb gnome-gmail-notifier` and once it has loaded, do the command `run`. If you could let us know the output of gdb, it should help to discover the cause of the problem.
Comment 4 Ian Weller 2009-03-20 13:45:21 EDT
(In reply to comment #3)
> Could I ask you to install gdb and run the following: `gdb
> gnome-gmail-notifier` and once it has loaded, do the command `run`. If you
> could let us know the output of gdb, it should help to discover the cause of
> the problem.  

Sam, make sure you run "debuginfo-install gnome-gmail-notifier" first.
Comment 5 Ian Weller 2009-03-20 13:46:21 EDT
(Also, Sam, gdb may also ask you to install some other debuginfo packages for it to work properly, too.)
Comment 6 Sam Stuewe 2009-03-22 22:53:08 EDT
(In reply to comment #5)
> (Also, Sam, gdb may also ask you to install some other debuginfo packages for
> it to work properly, too.)  

Okay well, I thoroughly hate to do this to you guys. But after booting up my compy again and reinstalling all the packages needed, it works like a charm. It connects and checks mail manually and automatically and everything else as well. I have no idea what the problem was, but seeing as it works now, the output of gdb shouldn't matter. Ian, you should update this bug report to read as null seeing as I'm the only one who has reported having the problem, and no one has been able to reproduce it.

Note You need to log in before you can comment on or make changes to this bug.