Bug 486791 - Add whois server for .nf (we're lacking that TLD completely)
Add whois server for .nf (we're lacking that TLD completely)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 23:12 EST by Robert Scheck
Modified: 2009-02-27 05:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 05:14:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-02-21 23:12:11 EST
Description of problem:
Add a whois server for .nf in /etc/jwhois.conf. I'm aware, that IANA doesn't
list one at http://www.iana.org/domains/root/db/nf.html, but Cocca is the only
technical and authoritative registry of .nf and provides really a working whois
server giving correct results. So let's use it...

Version-Release number of selected component (if applicable):
jwhois-4.0-10

How reproducible:
Everytime, whois query fails.

Actual results:
# whois names.nf
[Querying whois.internic.net]
[whois.internic.net]
[...]
#

Expected results:
Add the following line after "\\.net$" block in /etc/jwhois.conf:

  "\\.nf$" = "whois.cocca.cx";

Because it works as expected:

# whois -h whois.cocca.cx names.nf
[Querying whois.cocca.cx]
[whois.cocca.cx]
[...]
#

Additional info:
Please try to get this fix upstream - upstream is unluckily always very very
unresponsive to me.

Note You need to log in before you can comment on or make changes to this bug.