Bug 486799 - Update IPv6 block (cidr6-blocks { }) in /etc/jwhois.conf a bit
Update IPv6 block (cidr6-blocks { }) in /etc/jwhois.conf a bit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-21 23:50 EST by Robert Scheck
Modified: 2009-02-27 05:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 05:17:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-02-21 23:50:18 EST
Description of problem:
Update cidr6-blocks { } in /etc/jwhois.conf a bit, when looking to
http://www.iana.org/assignments/ipv6-unicast-address-assignments, the
following changes seem to be necessary. Please re-compare yourself,
maybe you find some mistakes or something to discuss - thank you...

Version-Release number of selected component (if applicable):
jwhois-4.0-10

How reproducible:
Everytime

Actual and expected results:

Replace: "2001:3800::/22" = "whois.ripe.net";
by     : "2001:3C00::/22" = "whois.iana.org";
Replace: "2001:4200::/23" = "whois.afrinic.net";
by     : "2001:4200::/23" = "whois.arin.net";

Add    : "2002:0000::/16" = "whois.ripe.net";
Remove : "2A00:0000::/12" = "whois.ripe.net";

Additional info:
Please try to get this fix upstream - upstream is unluckily always very very
unresponsive to me.
Comment 1 Vitezslav Crhonek 2009-02-25 06:49:04 EST
(In reply to comment #0)
> Description of problem:
> Update cidr6-blocks { } in /etc/jwhois.conf a bit, when looking to
> http://www.iana.org/assignments/ipv6-unicast-address-assignments, the
> following changes seem to be necessary. Please re-compare yourself,
> maybe you find some mistakes or something to discuss - thank you...
> 
> Version-Release number of selected component (if applicable):
> jwhois-4.0-10
> 
> How reproducible:
> Everytime
> 
> Actual and expected results:
> 
> Replace: "2001:3800::/22" = "whois.ripe.net";
> by     : "2001:3C00::/22" = "whois.iana.org";

IANA:
2001:3800::/22        RIPE NCC
2001:3C00::/22        RESERVED for possible future allocation to the RIPE NCC.

> Replace: "2001:4200::/23" = "whois.afrinic.net";
> by     : "2001:4200::/23" = "whois.arin.net";

IANA:
2001:4200::/23        AfriNIC

> 
> Add    : "2002:0000::/16" = "whois.ripe.net";

IANA:
2002:0000::/16        6to4

> Remove : "2A00:0000::/12" = "whois.ripe.net";

IANA:
2A00:0000::/12        RIPE NCC

> 
> Additional info:
> Please try to get this fix upstream - upstream is unluckily always very very
> unresponsive to me.

So please tell me why do you think that these changes should be made, it seems to be fine to me.
Comment 2 Robert Scheck 2009-02-25 07:47:57 EST
Looks it was too late, made a few copy/paste mistakes, sorry and thanks for
re-verifying. So just the following is what I need to claim here:

> 2001:0000::/23        IANA

Well, "whois -h whois.iana.org 2001:0000::1" returns nothing usable. I don't
know how to handle that, maybe just ignore and keep how it is until IANA fixes
their whois server somewhen.

> 2001:3C00::/22        RESERVED

"whois -h whois.ripe.net 2001:3C00::0" returns non-usable stuff while a
"whois -h whois.arin.net 2001:3C00::0" returns, that IANA is currently 
responsible and the address block is reserved for possible future use at
RIPE. If setting that whois server, we should maybe make a comment in the
configuration file as "not correct, but shows better information" or so.

> 2002:0000::/16        6to4

A regular whois to that IP space returns nothing usable. Maybe we should use
"whois -h whois.arin.net 2002:0000::0" which shows the correct information.
So if setting that whois server, we should maybe make a comment in the configuration file as "not correct, but shows better information". Former I
suggested to use "whois.ripe.net", but the output of "whois.arin.net" seems
to be much more useful to me.

In the end we could skip the first two if you disagree with my second 
suggestion, but the third (6to4) should really get a meaningful whois, as
these IPv6 addresses can be used already. Better ideas?

Note You need to log in before you can comment on or make changes to this bug.