Bug 486876 - Update spec templates to use %global instead of %define
Update spec templates to use %global instead of %define
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpmdevtools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
: 491771 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 15:41 EST by Toshio Ernie Kuratomi
Modified: 2009-05-06 19:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 07:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2009-02-22 15:41:31 EST
Description of problem:

The Fedora Packaging Guidelines have been updated to use %global instead of%define.  Justification is in the updated Guidelines:

https://fedoraproject.org/wiki/PackagingDrafts/global_preferred_over_define

The spec templates in rpmdevtools need to be updated to match.
Comment 1 Ville Skyttä 2009-02-22 15:57:31 EST
Done in git, will be in next 6.x and 7.x releases:
https://fedorahosted.org/rpmdevtools/changeset/e72325c4549c2aebf64ee32722c0d70b9dd63f1d
Comment 2 Ville Skyttä 2009-03-24 02:32:39 EDT
*** Bug 491771 has been marked as a duplicate of this bug. ***
Comment 3 Ville Skyttä 2009-04-04 07:57:50 EDT
Done in 6.8 and 7.1.
Comment 4 Fedora Update System 2009-05-06 19:28:03 EDT
rpmdevtools-7.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.