This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486882 - patch to fix epel compilation
patch to fix epel compilation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 17:13 EST by Levente Farkas
Modified: 2009-04-27 15:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 15:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2009-02-22 17:13:29 EST
please apply the patch bellow to be able to compile on epel-5 and older
fedoras.
thanks.
yours
-------------------------------------------------
--- gstreamer-plugins-base.spec	2009-01-20 20:43:53.000000000 +0100
+++ gstreamer-plugins-base.spec.new	2009-02-22 23:11:12.000000000 +0100
@@ -121,7 +121,11 @@
 %{_libdir}/gstreamer-%{majorminor}/libgstaudioresample.so
 %{_libdir}/gstreamer-%{majorminor}/libgstgdp.so
 %{_libdir}/gstreamer-%{majorminor}/libgstqueue2.so
+%if 0%{?fedora} >= 9
 %{_libdir}/gstreamer-%{majorminor}/libgstgio.so
+%else
+%{_libdir}/gstreamer-%{majorminor}/libgstgnomevfs.so
+%endif
 %{_libdir}/gstreamer-%{majorminor}/libgstapp.so
 
 # base plugins with dependencies
-------------------------------------------------
Comment 1 Adam Williamson 2009-02-23 14:59:13 EST
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Levente Farkas 2009-04-12 17:45:50 EDT
ping...
Comment 3 Adam Williamson 2009-04-13 11:43:13 EDT
CCing Bastien as he seems to be responsible for this package in practice.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Bastien Nocera 2009-04-27 15:21:01 EDT
That fix is broken, we don't require gnome-vfs2-devel anymore, so it wouldn't build like that in a build system.

Also, I'm not sure why we should make changes to the spec files to build in older distributions, or for EPEL to fork RHEL-5 packages.

Sorry, won't fix that.

Note You need to log in before you can comment on or make changes to this bug.