Bug 486884 - ntpd_initres: parent died before we finished, exiting
ntpd_initres: parent died before we finished, exiting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 17:40 EST by Bojan Smojver
Modified: 2009-02-24 09:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 09:19:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2009-02-22 17:40:21 EST
Description of problem:
Not exactly sure what the above means, but I see it in the log and it can't be good.

Version-Release number of selected component (if applicable):
4.2.4p6-1.fc10

How reproducible:
Sometimes.

Steps to Reproduce:
1. Restart ntpd.
  
Actual results:
Occasionally, the above message will appear in the log.

Expected results:
I thought that was fixed in p4.

Additional info:
Here is what the log looks like:
-----------------------------------------
Feb 23 09:24:13 beauty ntpd[7261]: ntpd exiting on signal 15
Feb 23 09:24:13 beauty ntpd[7969]: ntpd 4.2.4p6@1.1549-o Mon Jan 12 14:07:28 UTC
 2009 (1)
Feb 23 09:24:13 beauty ntpd[7970]: precision = 0.674 usec
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #0 wildcard, 0.0.0.0#1
23 Disabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #1 wildcard, ::#123 Di
sabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #2 lo, ::1#123 Enabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #3 eth1, fe80::2a0:c9f
f:fe04:bc84#123 Enabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #4 eth0, fe80::230:1bf
f:fe47:2dde#123 Enabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #5 lo, 127.0.0.1#123 E
nabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #6 lo:0, 150.101.121.1
79#123 Enabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #7 eth0, 10.1.120.1#12
3 Enabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on interface #8 eth1, 192.168.1.1#1
23 Enabled
Feb 23 09:24:13 beauty ntpd[7970]: Listening on routing socket on fd #25 for int
erface updates
Feb 23 09:24:13 beauty ntpd[7970]: kernel time sync status 0040
Feb 23 09:24:13 beauty ntpd[7970]: frequency initialized 46.699 PPM from /var/li
b/ntp/drift
Feb 23 09:24:15 beauty ntpd_initres[7263]: parent died before we finished, exiti
ng
-----------------------------------------
Comment 1 Adam Williamson 2009-02-23 14:53:46 EST
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Miroslav Lichvar 2009-02-24 09:19:14 EST
This happens when ntpd is stopped before name resolving has completed (which is done in a forked process). In the log, the resolving process 7263 belongs to ntpd 7261, not 7970. It's not really a bug, but rather a design feature.

Note You need to log in before you can comment on or make changes to this bug.