Bug 486907 - Hangs while suspending or hibernating (x86_64 bit, Intel graphics)
Hangs while suspending or hibernating (x86_64 bit, Intel graphics)
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-02-23 01:54 EST by mverdiell
Modified: 2009-12-18 03:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 03:00:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
pm-suspend.log (4.45 KB, application/octet-stream)
2009-02-23 01:54 EST, mverdiell
no flags Details

  None (edit)
Description mverdiell 2009-02-23 01:54:36 EST
Created attachment 332899 [details]

Description of problem: Hangs while suspending or hibernating. Console first shows normal process freeze or memory shrink reports, then hangs when last line on console says "suspending console". Computer and fans stay on, machine is unresponsive, no disk activity. Need to power cycle to revive. pm-suspend.log (attached) seems OK. Tried using nomodeset and no_console_suspend start options without luck. Fedora 10 x86_64, kernel Hardware is Shuttle SG45H7, Intel Core 2 Quad Q9300 + ICH10, 8Gb memory, using integrated graphics with Intel driver v.2.6.0.  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Select Suspend
Actual results:
System hangs, last line printed on console is "suspending console"

Expected results:

Additional info:
Comment 1 mverdiell 2009-03-29 02:39:17 EDT
correction: Intel graphics driver is 2.5.0, the one that comes with the distribution.
Comment 2 mverdiell 2009-03-31 04:04:03 EDT
Also tried the Intel graphics driver 2.6.0 version, same hang
Comment 3 mverdiell 2009-04-02 02:57:51 EDT
Also hangs on suspend with just vesa driver. Wrongly assumed it was a graphics driver problem obviously. Any hint which log I should look at to track the probable cause?
Comment 4 mverdiell 2009-04-03 02:02:29 EDT
Found the culprit. It's the driver for the WiFi add-in card from Realtech that causes the hang on suspend.

The driver name is rtl8187.

If I do: 
rmmod rtl8187 
before suspending it works fine.

Similar problem reported in:
bug 477346
bug 491235
bug 466621
Comment 5 Bug Zapper 2009-11-18 06:12:05 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 6 Bug Zapper 2009-12-18 03:00:58 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.