Bug 486916 - aldrin needs to be updated
aldrin needs to be updated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aldrin (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 02:43 EST by Orcan Ogetbil
Modified: 2009-03-19 09:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 17:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2009-02-23 02:43:24 EST
aldrin hasn't been touched in the rawhide for a while.

0.13 is out. Can you please update?
Comment 1 Fedora Admin XMLRPC Client 2009-02-23 02:44:29 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Orcan Ogetbil 2009-02-23 02:46:32 EST
uh oh. I see that the package is orphan. I'll handle this then.
Comment 3 Orcan Ogetbil 2009-03-13 17:05:29 EDT
imported and built in rawhide
Comment 4 oleg 2009-03-18 09:27:34 EDT
Hi

Could it be possible to have the fedora 10 rpm ?
thanks :)


Oleg.
Comment 5 Orcan Ogetbil 2009-03-18 11:37:09 EDT
It is in the testing repo. I filed a request for pushing it to stable yesterday. It should hit the stable repo in a couple days.

Meanwhile, if you don't want to wait, you can do a 
   yum --enablerepo updates-testing update aldrin
Comment 6 oleg 2009-03-18 12:18:07 EDT
that works perfectly thank you !

PS : I had to add the following environment variable :
export PYTHONPATH="/usr/lib/python2.5/site-packages/"



Oleg.
Comment 7 Orcan Ogetbil 2009-03-18 12:33:20 EDT
hmm, it works for me without setting an environment variable. What happens if you don't?
Comment 8 oleg 2009-03-18 12:53:29 EDT
I have then the following popup message :

libraries 'zzub' not found in /usr/local/lib64,/usr/local/lib,/usr/lib64,/usr/lib

Details 
Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/aldrin/com.py", line 89, in load_packages
  File "/usr/share/aldrin/components/iconfactory.py", line 28, in <module>
    from aldrin.utils import filepath, get_root_folder_path, iconpath, imagepath
  File "/usr/local/lib/python2.5/site-packages/aldrin/utils.py", line 26, in <module>
  File "/usr/local/lib/python2.5/site-packages/zzub/__init__.py", line 22, in <module>
  File "/usr/local/lib/python2.5/site-packages/zzub/zzub_flat.py", line 395, in <module>
  File "/usr/local/lib/python2.5/site-packages/zzub/procwrap.py", line 36, in dlopen
  File "/usr/local/lib/python2.5/site-packages/zzub/library.py", line 84, in load
AssertionError: libraries 'zzub' not found in /usr/local/lib64,/usr/local/lib,/usr/lib64,/usr/lib

...
hope that helps ;)
Oleg
Comment 9 Orcan Ogetbil 2009-03-18 12:57:46 EDT
Did "yum --enablerepo updates-testing update aldrin" also install the package armstrong on your computer, or do you have the old libzzub installed? (armstrong replaces libzzub)

Can you post me your
    rpm -q aldrin armstrong libzzub
output?
Comment 10 oleg 2009-03-18 13:04:34 EDT
] rpm -q aldrin armstrong libzzub
aldrin-0.13-1.fc10.noarch
armstrong-0.2.6-4.fc10.i386
package libzzub is not installed


I don't think I have any libzzub on my machine.
I recently build armstrong/aldrin from source and I had to set the PYTHONPATH="/usr/local/lib/python2.5/site-packages/" to make it work...
Comment 11 oleg 2009-03-18 13:13:03 EDT
btw you can easily reproduce the pb : 
] python
Python 2.5.2 (r252:60911, Sep 30 2008, 15:41:38) 
[GCC 4.3.2 20080917 (Red Hat 4.3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import zzub
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/PIL/__init__.py", line 22, in <module>
    
  File "/usr/local/lib/python2.5/site-packages/zzub/zzub_flat.py", line 395, in <module>
  File "/usr/local/lib/python2.5/site-packages/zzub/procwrap.py", line 36, in dlopen
  File "/usr/local/lib/python2.5/site-packages/zzub/library.py", line 84, in load
AssertionError: libraries 'zzub' not found in /usr/local/lib64,/usr/local/lib,/usr/lib64,/usr/lib
>>> 


I will try to find a fresh machine to check it.
Comment 12 Orcan Ogetbil 2009-03-18 13:45:13 EDT
I can import zzub in python with no problems. It might be a problem with your setup.
Comment 13 oleg 2009-03-19 09:52:04 EDT
I confirm aldrin install works out of the box on a fresh fc10 machine,
so my setup is definitely crap :)

Note You need to log in before you can comment on or make changes to this bug.