Bug 486939 - hald fails to start at boot when /var/cache/hald does not exist
hald fails to start at boot when /var/cache/hald does not exist
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 07:03 EST by Douglas Silas
Modified: 2014-06-09 07:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 03:01:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Silas 2009-02-23 07:03:04 EST
Description of problem:
hald cannot recreate /var/cache/hald

Version-Release number of selected component (if applicable):
HAL package version: 0.5.12
Linux 2.6.27.5-117.fc10.x86_64 #1 SMP Tue Nov 18 11:58:53 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
Name        : hal                          Relocations: (not relocatable)
Version     : 0.5.12                            Vendor: Fedora Project
Release     : 14.20081027git.fc10           Build Date: Mon 22 Dec 2008 11:14:41 PM CET
Install Date: Mon 19 Jan 2009 08:30:44 AM CET      Build Host: x86-1.fedora.phx.redhat.com
Group       : System Environment/Libraries   Source RPM: hal-0.5.12-14.20081027git.fc10.src.rpm
Size        : 1409113                          License: AFL or GPLv2
Signature   : DSA/SHA1, Wed 14 Jan 2009 03:59:53 AM CET, Key ID bf226fcc4ebfc273
Packager    : Fedora Project

How reproducible:
Delete /var/cache/hald


Steps to Reproduce:
1.rm /var/cache/hald -fr
2.Reboot
3.
  
Actual results:
hald fails to start at boot; GDM loads but xorg does not have access to useful hardware such as keyboard or mouse; cannot log in, etc. Make sure to have a luks-encrypted volume or two for more fun.
hald fails to start because it cannot recreate /var/cache/hald

Expected results:
hald recreates /var/cache/hald, sets the appropriate permissions on the directory, and trundles onward.

Additional info:
Comment 1 Scott Glaser 2009-09-09 09:11:46 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bug Zapper 2009-11-18 06:12:28 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-12-18 03:01:08 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.