Bug 487003 - takes three times to resume from suspend on thinkpad T500
takes three times to resume from suspend on thinkpad T500
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 483658 510848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 11:47 EST by Cameron Meadors
Modified: 2009-08-23 16:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-23 16:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-power-manager --verbose log (2.68 KB, text/plain)
2009-07-12 23:58 EDT, Samuel Sieb
no flags Details

  None (edit)
Description Cameron Meadors 2009-02-23 11:47:24 EST
Description of problem:

When I suspend my T500, it takes three attempts to resume.  The first and second resume attempts, power up the system and I briefly see the screensaver dialog before the system suspends again. The third time it works.  Not sure what part of the stack is breaking so I am starting at the top.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.24.4-1.fc10.x86_64
dbus-1.2.4-2.fc10.x86_64
hal-0.5.12-14.20081027git.fc10.x86_64
kernel-2.6.27.15-170.2.24.fc10.x86_64

How reproducible:
Every time I suspend

Steps to Reproduce:
1. Log in
2. Suspend
3. Try to resume (using the Fn key, keep forgetting to try the power button)
  
Actual results:
fails to resume the first two times, going back to suspend each time, then resuming correctly the third time

Expected results:
Resumes on the first try.

Additional info:
I see messages like this in .xsession-errors:

** (gnome-power-manager:3100): WARNING **: DBUS timed out, but recovering
** (gnome-power-manager:3100): WARNING **: DBUS timed out, but recovering
** (gnome-power-manager:3100): WARNING **: Suspend failed without error message
Comment 1 Cameron Meadors 2009-03-18 15:52:51 EDT
If I use g-p-m applet menu to suspend, resume works.  I was using Fn+F4 to suspend when it fails to resume.
Comment 2 Andrew Hecox 2009-07-12 09:27:07 EDT
*** Bug 483658 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Hecox 2009-07-12 09:28:02 EDT
*** Bug 510848 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Hecox 2009-07-12 09:29:55 EDT
this is still a problem in F11; see equivalent launchpad bug here:

 (https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/261084
Comment 5 Andrew Hecox 2009-07-12 09:34:00 EDT
using xev, I can see an event sent three times when using fn+f4 -- I don't know if that's *the* event or not but:

MappingNotify event, serial 27, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 247

MappingNotify event, serial 31, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 248

MappingNotify event, serial 31, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 247
Comment 6 Samuel Sieb 2009-07-12 23:57:36 EDT
I only get the suspend twice, not three times.  It was working properly in F10 until I upgraded to F11.  It's not just x86_64, I'm using 32-bit.

I've discovered where the problem is for mine.  g-p-m gets the event both from hal and X and acts on both.  Somehow it needs to realize that it only needs one of them and to ignore the other.  Using xev I only see one key event sent.  I'll attach a partial log from g-p-m and you can see that first it gets the X key event, suspends, resumes, then gets the hal event and does it all again.  It would be interesting to get a log from the triple suspend to see what is happening there.
Comment 7 Samuel Sieb 2009-07-12 23:58:12 EDT
Created attachment 351425 [details]
gnome-power-manager --verbose log
Comment 8 Charles R. Anderson 2009-07-16 00:39:30 EDT
Same problem on Thinkpad T61.
Comment 9 Ian Page Hands 2009-08-23 07:07:05 EDT
Fixed for me!

Works after grabbing todays evdev and gpm packages from updates-testing.
xorg-x11-drv-evdev-2.2.5-1.fc11.i586
gnome-power-manager-2.26.4-3.fc11.i586


Whomever fixed it is awesome! :-)
I hated this bug. Mashing the suspend hot key was so tempting, but waiting for 2-4 thaws was painful.

Note You need to log in before you can comment on or make changes to this bug.