Bug 487005 - booting from local disk option of the installation media bootloader does not work within virtual machine
booting from local disk option of the installation media bootloader does not ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 623629
  Show dependency treegraph
 
Reported: 2009-02-23 11:53 EST by Karel Volný
Modified: 2011-12-13 13:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 623629 (view as bug list)
Environment:
Last Closed: 2011-12-13 13:57:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-02-23 11:53:56 EST
Description of problem:
I have installed Rawhide as a xen guest. When I leave the system to boot from the image boot.iso, there is an option to boot the system from the local disk, but it does not work for me.

Version-Release number of selected component (if applicable):
(version that was available on Feb 19)

How reproducible:
always

Steps to Reproduce:
1. install Rawhide as xen guest
2. mount boot.iso as the cdrom image, set the machine to boot from cd and start it
3. select "Boot from local drive"

Actual results:
Booting from local disk...
FATAL: No bootable device.

Expected results:
(the installed guest system starts normally)

Additional info:
the guest harddrive is a partition (not an image file)

I am really not sure about the component assignment, but since I do not see anything for isolinux (is it the name?), Anaconda is what comes to my mind next ;-)
Comment 1 Chris Lumens 2009-03-26 15:06:55 EDT
If you don't have the boot.iso attached as a CD drive, can you boot the local drive then?  That is, does the bootloader installed by anaconda even work?
Comment 2 Karel Volný 2009-03-27 16:10:35 EDT
(In reply to comment #1)
> If you don't have the boot.iso attached as a CD drive, can you boot the
> local drive then?  That is, does the bootloader installed by anaconda even
> work?

yes, I can boot the system from the "harddisk" if the CD is not involved
Comment 3 Jeremy Katz 2009-05-04 09:15:41 EDT
What version of Xen stuff are you running as the host?  I have a vague memory of a bochs bug causing this that got fixed (and bochs is used for the Xen full-virt bios)
Comment 4 Karel Volný 2009-05-11 11:50:14 EDT
(In reply to comment #3)
> What version of Xen stuff are you running as the host?  I have a vague memory
> of a bochs bug causing this that got fixed (and bochs is used for the Xen
> full-virt bios)  

[root@dhcp-lab-227 yum.repos.d]# rpm -qa |grep xen
xen-libs-3.0.3-80.el5_3.2
kernel-xen-2.6.18-128.el5virttest3
kernel-xen-2.6.18-128.1.6.el5
xen-3.0.3-80.el5
xen-libs-3.0.3-80.el5
kernel-xen-2.6.18-128.1.1.el5

... sorry, not in the mood to reboot now to verify if all kernel-xen versions behave the same (but I bet yes)
Comment 5 Bug Zapper 2009-06-09 07:35:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Karel Volný 2010-02-23 10:51:33 EST
I've just verified that the same happens to me with Fedora 12 using qemu with image file

Steps to Reproduce:
1. install whatever you prefer into virtual machine (I assume image file F12.qcow)
2. qemu -m 512 -cdrom boot.iso -boot d F12.qcow2
3. select "Boot from local drive"

the result is the same -
Booting from local disk...
FATAL: No bootable device.

I've tried also to boot from Fedora-12-i386-DVD.iso and Fedora-12-i386-netinst.iso and the beahaviour is the same.
Comment 7 danielpay@gmail.com 2010-04-27 06:55:52 EDT
I have this problem with Red Hat Enterprise Linux 6.0 Beta i386 and virtualbox 3.1.6 ose
Comment 10 Karel Volný 2010-08-12 07:11:36 EDT
updating version, as the problem is reproducible also with Fedora-13-i386-DVD.iso
Comment 11 Karel Volný 2011-02-17 08:37:07 EST
still valid
Comment 12 Karel Volný 2011-12-13 13:57:03 EST
I cannot reproduce this with Fedora 16, seems it got fixed meanwhile

Note You need to log in before you can comment on or make changes to this bug.