Bug 487011 - multi-org, systems subscribed to unshared channel after trust removal
multi-org, systems subscribed to unshared channel after trust removal
Status: CLOSED DUPLICATE of bug 494409
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
wes hayutin
http://grandprix.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 456998 486216 494409
  Show dependency treegraph
 
Reported: 2009-02-23 12:13 EST by wes hayutin
Modified: 2009-07-30 14:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 494409 (view as bug list)
Environment:
Last Closed: 2009-07-30 14:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-02-23 12:13:55 EST
Description of problem:

create 2 orgs  A,B
org A share a protected channel to org B
register system to org B
make system bash channel, the shared channel from orgA
In orgA remove access to channel, by navigating to the channel -> orgs, uncheck orb B.
click submit

expected results:
systems using this channel will have the channel removed


actual resutls:
system remains subsscribed to shared channel in the webui.
click on the channel in the consuming org.. get 404 
The channel doesnt really exist
Comment 1 Shannon Hughes 2009-02-27 15:24:21 EST
we were missing the unsubscribe logic on this page. added support. moving to modified
Comment 2 wes hayutin 2009-03-09 17:57:34 EDT
nice.. this is working..
verified
Comment 3 wes hayutin 2009-04-02 11:35:32 EDT
this is no longer working.. 
ISO: Satellite-5.3.0-RHEL5-re20090327.0-i386-embedded-oracle.iso
Comment 4 Shannon Hughes 2009-04-02 14:07:24 EDT
will take a look.
Comment 5 Shannon Hughes 2009-04-06 14:52:18 EDT
this path is actually working but we both tested the admin side which is not working. opened up another bug for this, 

#494409

moving this bug back to onqa per weshay request.
Comment 6 wes hayutin 2009-04-22 09:16:26 EDT
verified 4/14
Comment 7 wes hayutin 2009-07-30 14:07:27 EDT

*** This bug has been marked as a duplicate of bug 494409 ***

Note You need to log in before you can comment on or make changes to this bug.