Bug 487031 - Remove producer throttling
Remove producer throttling
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
high Severity high
: ---
: ---
Assigned To: Ken Giusti
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 13:44 EST by Gordon Sim
Modified: 2015-11-15 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version: qpid-0.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 18:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2009-02-23 13:44:48 EST
Flow control commands are sent out through broker::SessionState on a timer thread. If this happens concurrently with e.g. dispatch of message for a subscriber on that session, or when writing out the response/completion for a command other than transfer, there could be corruption of the output stream or other problems as all output is currently assumed to be done serially on the io thread.
Comment 1 Andrew Stitcher 2009-02-25 11:24:01 EST
This isn't testable except by finding a soak test that fails oddly
Comment 2 Justin Ross 2011-06-28 14:20:11 EDT
Gordon, can this be closed?
Comment 3 Gordon Sim 2011-06-28 14:41:40 EDT
It certainly looks like the code was changed.

I think the best thing would be to remove the feature entirely. I don't believe anyone uses it and I don't think it is actually useful. I also don't believe there are any tests for it and I suspect QE don't test it either.
Comment 4 Justin Ross 2011-06-29 14:57:19 EDT
Turning this into a request to remove the producer throttling feature.  It's not currently in use, and it has no tests.
Comment 5 Justin Ross 2011-11-09 17:22:49 EST
Ken, is the old producer-throttling now removed?
Comment 6 Ken Giusti 2011-11-14 14:25:30 EST
No it hasn't been.  I've opened an upstream JIRA to issue a warning should that feature be used:

https://issues.apache.org/jira/browse/QPID-3615

Probably the polite thing to do for 0.14, then rip it out entirely in 0.15 (?)
Comment 7 Justin Ross 2011-11-14 14:31:04 EST
Thanks. I think that's the right plan.
Comment 8 Ken Giusti 2012-01-13 14:01:02 EST
Removed this from upstream in 0.15 development branch.

http://svn.apache.org/viewvc?view=rev&rev=1231221
http://svn.apache.org/viewvc?view=rev&rev=1231222

Note You need to log in before you can comment on or make changes to this bug.