Bug 487047 - libgwheater unfortunate data source choice for Edmonton, Alberta
libgwheater unfortunate data source choice for Edmonton, Alberta
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libgweather (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 15:27 EST by Michal Jaegermann
Modified: 2009-03-05 15:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 11:28:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to turn off CXEC for Edmonton (667 bytes, patch)
2009-03-01 22:48 EST, Michal Jaegermann
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2009-02-23 15:27:04 EST
Description of problem:

After an update of libgweather to 2.25.91-1.fc11 a wheather displayed for Edmonton, Alberta, Canada by a clock-applet is consistently missing a sky and wind information.  This is not the case if you will pick up some other locations; either in a relative vicinity or far away.  Also on F9 and F10 installations the missing information is displayed.

In the past it was possible to choose between few different wheather data sources for Edmonton and one of these was, say, "rather limited".  Apparently that "bad" one is now used and there is no way to replace it with something else.

Version-Release number of selected component (if applicable):
libgweather-2.25.91-1.fc11.x86_64

How reproducible:
all the time
Comment 1 Matthias Clasen 2009-02-25 12:24:56 EST
Can your figure out what that better location is ?
Comment 2 Michal Jaegermann 2009-02-25 12:51:15 EST
> Can your figure out what that better location is ?

Why not to use the same source for data as in F9 and F10 where this works?

In any case - I remember vaguely that sometime in the past (or maybe in some other application?) for Edmonton I had a choice between stations:
- Edmonton International Airport
- Edmontont City Centre Airport
- Edmonton CSIR (or something like that, whatever that may mean)
- ... and possibly something else too

It was that "CSIR" that provided only temperature data and any other choice
was giving a more complete picture.  Currently this is only "Edmonton" and
that is it.  Apparently that "CSIR" is picked up in F11 for whatever reasons
while "Edmontont City Centre Airport" is likely "the best" in the situation.
Comment 3 Matthias Clasen 2009-02-25 13:20:18 EST
> Why not to use the same source for data as in F9 and F10 where this works?

Sure, I'm just trying to get you to give me a patch...
Comment 4 Michal Jaegermann 2009-02-25 14:37:17 EST
> Sure, I'm just trying to get you to give me a patch...

:-) Frankly, I have no idea what libgwheater does internally nor I have any
sources for that on hands.  I thought that this is sort of "obvious" for somebody
familiar with this library.  When I will have some time I may try to dig through
sources and figure out how data enquires there work.
Comment 5 Michal Jaegermann 2009-03-01 22:48:23 EST
Created attachment 333676 [details]
patch to turn off CXEC for Edmonton

> Sure, I'm just trying to get you to give me a patch...

Just what I thought.  In Locations.xml.in the first station for Edmonton is "Edmonton Municipal CR10", code CXEC, which gives incomplete data.  With the patch attached a recompiled libgweather does not show "Unknown" lines but data. One needs to remove Edmonton from "Locations" in clock-applet and add it again, though, before this is noticed.  A station code is stored somewhere?

Now these station data do not differ really from what is used by libgweather-2.24.2 in F10 and there a display is as expected.  Apparently a luck of a draw.  I have no idea how clock-applet is making its choices.  There were times when it was possible to pick up from a list of possibilities but apparently some clueless person decided to "simplify" things making them much harder and incorrect.  A weather at "Edmonton Municipal" and "Edmonton International" can be quite dramatically different at times and it looks like that if one is interested in the later then tough luck.

BTW - there is also /usr/share/evolution-data-server-2.26/weather/Locations.xml
but this file is quite different than the one used by libgweather and covers only USA hence is of a very limited use elsewhere.
Comment 6 Dan Winship 2009-03-03 11:28:27 EST
pushed upstream: http://bugzilla.gnome.org/show_bug.cgi?id=573936
Comment 7 Michal Jaegermann 2009-03-05 15:12:20 EST
For a benefit of those who will be hit but the same or similar problems.  It is possible to change data source by editing "code" part in 'cities' for one of
/apps/panel/applets/... gconf key (which one depends on a desktop layout).  Nothing else needs to be changed.

Station codes can be found in installed data but due to their format (one long line) this is not so readable so something like that may help:

  tr '>' '\n' </usr/share/libgweather/Locations.xml | less

In case of Edmonton an information between CYXD (Edmonton Municipal) and  CYEG (Edmonton International) may differ quite substantially and CXEC is very limited.

Note You need to log in before you can comment on or make changes to this bug.