Bug 487095 - RFE - Newer version of ImageMagick to incorporate almost a year of fixes.
RFE - Newer version of ImageMagick to incorporate almost a year of fixes.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
http://www.imagemagick.org
RFE ImageMagick package update to cur...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 01:24 EST by Robin Laing
Modified: 2009-03-10 01:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 07:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Laing 2009-02-24 01:24:11 EST
Description of problem:
The present version of ImageMagick provided by Fedora is almost a year old.  There have been many patches and libraries for associated applications are also updated.  Some applications that use ImageMagick require these new libraries.

Version-Release number of selected component (if applicable):
ImageMagick-6.4.0.10-2.fc10.i386

How reproducible:
This is an Request for Enhancement.


Steps to Reproduce:
1.  Install the latest ImageMagick
2.  Compare versions from ImageMagick.org
3.  Or try to compile or use some newer applications that require updated libraries.

 
Actual results:
Some newer applications won't run or compile against the supplied version.  Some ImageMagick based script won't run against this version.

Expected results:
Current version has almost a years fixes and some applications now need libMagick.so.10 as well as libMagick++.so.10 that I have tried to install or compile.

Additional info:
This is from the current stable version of ImageMagick source.  6.4.0-10 is from 2008-04-20.  The latest version is now  6.4.9-5

2008-04-20  6.4.0-10 Chris Madison  <madisonblu@hotma...>
2009-02-18  6.4.9-5 Jon  <jon@brick...>

I read through the changelog and I see that over the year, there have been many fixes for memory leaks, file management, image handling and added features.  I did a quick count and there are almost 150 patches and fixes (Not all affect Linux) that have occurred.

In my particular case, the improvements and changes to the -fx function alone are needed to run various scripts that require at least 6.4.2.

Thank you.
Comment 1 Hans de Goede 2009-03-09 07:06:29 EDT
I've created an update to 6.4.9-6 for rawhide (development branch which will become F-11). I cannot update ImageMagick in F-10, since ImageMagick upstream has broken binary compatibility, so this would break applications which are using the
ImageMagick libraries.

The new ImageMagick will be in tomorrows rawhide build
Comment 2 Robin Laing 2009-03-10 01:10:38 EDT
Thank you for the update.

Note You need to log in before you can comment on or make changes to this bug.