Bug 487107 - unnecessary launchpad files are packaged in the -devel subpackage
unnecessary launchpad files are packaged in the -devel subpackage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.6.0-ibm (Show other bugs)
4.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Lillian Angel
BaseOS QE
:
Depends On:
Blocks: 524003
  Show dependency treegraph
 
Reported: 2009-02-24 04:48 EST by Radek Bíba
Modified: 2009-10-12 09:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 524003 (view as bug list)
Environment:
Last Closed: 2009-10-12 09:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2009-02-24 04:48:12 EST
Description of problem:
The following files in /usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3 aren't needed at all on Linux:

autorun.inf
launchpad.exe
launchpad.ini
launchpad/*.bat

because they are DOS/Windows-only. On Linux systems, launchpad.sh and lauchpad/*.sh are being used.

Also, I doubt it makes sense to have all the splash directories and files for all UNIX-like OS/arches one could think of (launchpad/splash/: aixppc, hpuxia64, hpuxparisc, linuxppc, linuxs390, linuxx86, sunsparc, sunx86). I guess even the RHEL-related files could be excluded as no splash screen is apparently displayed when launchpad.sh is run. On RHEL 4, this is in fact printed to the terminal:

+ seamonkey -nosplash -P IBM_LaunchPad_25712 file:///usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad/Mozilla.html

so I guess the -nosplash parameter explains that. In fact, when I tried to run the right 'splash', linuxppc/AZY_Splash on a ppc box, it didn't work. First, no binary in launchapad/splash/* has the 'executable' bit set, and even after if I set it, it did nothing visible. Strace said it failed to open AZY_Splash.ini and exited. launchpad/splash.sh, when I examined it, expects some splash.ini in the java-1.6.0-ibm-devel 'main' directory, but it's not there.

So, please don't include the DOS files in the package, and fix or remove the splash stuff.
Comment 1 Lillian Angel 2009-09-17 11:34:49 EDT
*** Bug 487105 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2009-10-12 09:17:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1492.html

Note You need to log in before you can comment on or make changes to this bug.