Bug 487163 - mkinitrd fails to load required disk controller modules before looking for software raids
mkinitrd fails to load required disk controller modules before looking for so...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 11:35 EST by Jarod Wilson
Modified: 2009-03-17 10:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 10:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkinitrd -v w/o any preload added (from ppc64 box that needs ipr) (9.31 KB, text/plain)
2009-02-26 10:53 EST, Jarod Wilson
no flags Details
mkinitrd -v w/preload ipr added (9.31 KB, text/plain)
2009-02-26 10:54 EST, Jarod Wilson
no flags Details

  None (edit)
Description Jarod Wilson 2009-02-24 11:35:53 EST
Description of problem:
mkinitrd fails to include required disk controller modules lately. Two boxes of mine that work just fine with F10 fail to boot w/rawhide. One is an x86_64 machine w/its root volume on a sata_svw-driven controller, one is a ppc64 machine w/its root volume on an ipr-driven controller. If I manually run mkinitrd w/--preload={sata_svw,ipr}, then the machines can boot again.

Possibly of relevance, both have their root volumes on software RAID arrays.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.78-1.fc11


How reproducible:
Install rawhide mkinitrd and kernel on a box that doesn't have its root volume on a disk attached to a controller which has its module built into the kernel now.
Comment 1 Hans de Goede 2009-02-24 14:13:21 EST
Hmm,

Can you please run mkinitrd -v .... &> log on this boxes and attach the resulting log files?

Thanks!
Comment 2 Jarod Wilson 2009-02-26 10:53:39 EST
Created attachment 333341 [details]
mkinitrd -v w/o any preload added (from ppc64 box that needs ipr)
Comment 3 Jarod Wilson 2009-02-26 10:54:38 EST
Created attachment 333342 [details]
mkinitrd -v w/preload ipr added

Here ya go. Can also provide remote access to the box, if so desired.
Comment 4 Jarod Wilson 2009-02-26 10:57:30 EST
Hadn't actually looked at those closely 'til now. Both include the ipr module, but w/o the preload, the software raid module gets loaded first, and the arrays aren't found because the disks aren't accessible yet. I never see any evidence of the disk controller module actually loading though, even after the raid module has already loaded.
Comment 5 Hans de Goede 2009-02-26 14:05:29 EST
I don't think the order of loading the modules is the issue. Access to a box with this problem would be great, can you contact me on irc about this? I'm hansg both on internal irc as on freenode.
Comment 6 Jarod Wilson 2009-03-17 10:02:27 EDT
Okay, so this seems to have been a transient rawhide failure, probably kernel-side, which is now resolved on both my ipr and sata_svw boxes w/2.6.29-rc8 and later, no work-arounds required at all to get them booting properly.

Note You need to log in before you can comment on or make changes to this bug.