Bug 487252 - Build with --enable-fixed-rrset
Build with --enable-fixed-rrset
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 20:29 EST by Bernie Innocenti
Modified: 2013-04-30 19:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 06:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernie Innocenti 2009-02-24 20:29:22 EST
This is required in order to make the following configuration work as expected:

rrset-order {
	type PTR order fixed;
	order cyclic;
};

I don't know what the impact is on performance and other features, but there might be a reason why this is not enabled by default.
Comment 1 Adam Tkac 2009-03-04 12:10:38 EST
It will significantly increase memory footprint. Could you please specify why do you need exact rrset order, please?
Comment 2 Bernie Innocenti 2009-03-04 17:12:18 EST
(In reply to comment #1)
> It will significantly increase memory footprint. Could you please specify why
> do you need exact rrset order, please?

It allows one to have several PTR records to match all the A records of a machine, while clients will generally pick only the first one.

Having correct PTR records for ns1.example.com is a requirement for nameservers in some TLDs, but if the IP is associated with several services, you don't want "ns1.example.com" to show up randomly for your host.

Anyway, if it considerably increses memory usage, we can probably live without.
Comment 3 Adam Tkac 2009-03-09 06:58:40 EDT
If you are able to setup your machines without rrset-order option it would be nice because additional memory consumtion with fixed rrsets is non-trivial.

I'm closing this bug for now. If you _really_ need named build with --enable-fixed-rrset please reopen this bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.