Bug 487282 - Proxy could not find repomd.xml on satellite proxy channel
Proxy could not find repomd.xml on satellite proxy channel
Status: CLOSED DUPLICATE of bug 474081
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
520
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Jeff Browning
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 05:28 EST by Jean-Pierre Joerg
Modified: 2009-03-09 21:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 07:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errata ID 1051 Screenshiot (14.13 KB, image/png)
2009-03-06 04:51 EST, Stefan Kutzke
no flags Details
Errata ID 1050 Screenshiot (24.05 KB, image/png)
2009-03-06 04:52 EST, Stefan Kutzke
no flags Details

  None (edit)
Description Jean-Pierre Joerg 2009-02-25 05:28:47 EST
Description of problem:
The rhn proxy (5.2) is not able to finish it's  installation step because of missing repomd.xml when trying to download it's installation files from proxy channel on satellite (5.2)

Version-Release number of selected component (if applicable): RHN proxy 5.2 and RHN satellite 5.2


How reproducible: Always


Steps to Reproduce:
1.Rhn_check on proxy after the proxy installation step on Satellite 
2.
3.
  
Actual results: Could not find repomd.xml


Expected results:dowload packages from satellite for proxy installation


Additional info:Always reproductible
Comment 1 Miroslav Suchý 2009-02-26 03:30:40 EST
It is possible that the repomd "just" has not been created? It takes some time to create it and first hits usually timeouted. 
Can you try to do this steps after setup:
1. yum install NPalert
2. wait 10 minutes
3. only then run rhn_check

If this succeed then this is duplicate of bug already fixed under satellite 530. If not, then it will be new bug.
Comment 2 Jean-Pierre Joerg 2009-03-05 04:12:15 EST
I'm not able to do any more tests before 3 or 4 weeks. I have no satellite and proxy accessible for the moment. I will try to find a way but no guaranty sorry for this.
Comment 3 Stefan Kutzke 2009-03-05 12:38:56 EST
> If this succeed then this is duplicate of bug already fixed under satellite
> 530. If not, then it will be new bug.
It doesn't help. Proxy Channel has ID 110 on my Satellite, there is no file named repomd.xml-110:

[root@satellite rhn]# ll *110
-rw-r--r--  1 apache apache 149114 Mar  5 17:04 repomd_filelists.xml-110
-rw-r--r--  1 apache apache  17255 Mar  5 17:04 repomd_filelists.xml.gz-110
-rw-r--r--  1 apache apache 162950 Mar  5 17:04 repomd_other.xml-110
-rw-r--r--  1 apache apache  17414 Mar  5 17:04 repomd_other.xml.gz-110
-rw-r--r--  1 apache apache 297999 Mar  5 17:04 repomd_primary.xml-110
-rw-r--r--  1 apache apache  29837 Mar  5 17:04 repomd_primary.xml.gz-110
-rw-r--r--  1 apache apache     49 Mar  5 18:29 repomd_updateinfo.xml-110

The problem seems to be this file:
[root@satellite rhn]# cat repomd_updateinfo.xml-110
<?xml version="1.0" encoding="UTF-8"?>
<updates>

It looks incomplete.

I removed all files named repomd*-110. After running "yum list available" on my proxy machine the result was the same as above.
Comment 4 Stefan Kutzke 2009-03-05 12:48:16 EST
> If this succeed then this is duplicate of bug already fixed under satellite
> 530. If not, then it will be new bug.
It doesn't help. Proxy Channel has ID 110 on my Satellite, there is no file named repomd.xml-110:

[root@satellite rhn]# ll *110
-rw-r--r--  1 apache apache 149114 Mar  5 17:04 repomd_filelists.xml-110
-rw-r--r--  1 apache apache  17255 Mar  5 17:04 repomd_filelists.xml.gz-110
-rw-r--r--  1 apache apache 162950 Mar  5 17:04 repomd_other.xml-110
-rw-r--r--  1 apache apache  17414 Mar  5 17:04 repomd_other.xml.gz-110
-rw-r--r--  1 apache apache 297999 Mar  5 17:04 repomd_primary.xml-110
-rw-r--r--  1 apache apache  29837 Mar  5 17:04 repomd_primary.xml.gz-110
-rw-r--r--  1 apache apache     49 Mar  5 18:29 repomd_updateinfo.xml-110

The problem seems to be this file:
[root@satellite rhn]# cat repomd_updateinfo.xml-110
<?xml version="1.0" encoding="UTF-8"?>
<updates>

It looks incomplete.

I removed all files named repomd*-110. After running "yum list available" on my proxy machine the result was the same as above.
Comment 5 Brandon Perkins 2009-03-05 13:45:00 EST
Please run a fresh satellite-sync of the Proxy channel, wait 10-20 minutes, then try this process again and report any results.
Comment 6 Stefan Kutzke 2009-03-05 14:18:44 EST
I have done a fresh satellite-sync:

satellite-sync --channel redhat-rhn-proxy-5.2-server-i386-5

Same results - repomd_updateinfo.xml-110 is incomplete:
[root@satellite rhn]# cat repomd_updateinfo.xml-110
<?xml version="1.0" encoding="UTF-8"?>
<updates>

I have done some more troubleshooting:

There is an errata in the Proxy Channel: RHEA-2009:0273

The corresponding file is:
/var/cache/rhn/repomd-errata/1051

If I view this file with Midnight Commander - it looks very different from all other files in /var/cache/rhn/repomd-errata.

Could this be the reason of the problem?
Comment 7 Stefan Kutzke 2009-03-05 15:23:40 EST
Well, I was on the right way :-)

I have done the following steps:

1) Removed the Proxy channel from my Satellite:
PYTHONPATH=/usr/share/rhn/ python satellite_tools/satrm.py --channel redhat-rhn-proxy-5.2-server-i386-5

2) Removed corresponding files from /var/cache/rhn:
rm -f /var/cache/rhn/*110

3) Removed the strange file for errata "RHEA-2009:0273":
rm -f /var/cache/rhn/repomd-errata/1051

4) Done a fresh satellite-sync of the Proxy channel WITHOUT erratas:
satellite-sync --channel redhat-rhn-proxy-5.2-server-i386-5 --no-errata

5) Done a new Proxy installation without any problems.

The new channel ID for the Proxy channel is 135 on my Satellite:
[root@satellite rhn]# ll *135
-rw-r--r--  1 apache apache 149114 Mar  5 21:06 repomd_filelists.xml-135
-rw-r--r--  1 apache apache  17255 Mar  5 21:06 repomd_filelists.xml.gz-135
-rw-r--r--  1 apache apache 162950 Mar  5 21:06 repomd_other.xml-135
-rw-r--r--  1 apache apache  17414 Mar  5 21:06 repomd_other.xml.gz-135
-rw-r--r--  1 apache apache 297999 Mar  5 21:06 repomd_primary.xml-135
-rw-r--r--  1 apache apache  29910 Mar  5 21:06 repomd_primary.xml.gz-135
-rw-r--r--  1 apache apache     60 Mar  5 21:06 repomd_updateinfo.xml-135
-rw-r--r--  1 apache apache     73 Mar  5 21:06 repomd_updateinfo.xml.gz-135
-rw-r--r--  1 apache apache   1239 Mar  5 21:06 repomd.xml-135

The file repomd_updateinfo.xml-135 is now complete:
 [root@satellite rhn]# cat repomd_updateinfo.xml-135
<?xml version="1.0" encoding="UTF-8"?>
<updates>

</updates>[root@satellite rhn]#


This bug should be fixed as quick as possible!
Comment 8 Brandon Perkins 2009-03-05 17:07:35 EST
Miroslav, can you take a quick look at this and see if there is anything obvious that is different about this case than all the other Proxy servers in the wild?
Comment 9 Stefan Kutzke 2009-03-06 03:50:13 EST
I have reproduced the problem.

I have removed /var/cache/rhn/*135 - the repo files for the Proxy channel with ID 135 on my Satellite.

After that I have done a satellite-sync.

Now the errata "RHEA-2009:0273" is available in the Proxy channel.

On my proxy machine:
[root@rhnproxy yum]# yum clean all
Loaded plugins: rhnplugin, security
Cleaning up Everything
[root@rhnproxy yum]# yum list available
Loaded plugins: rhnplugin, security
rhel-i386-server-5                                                           | 1.4 kB     00:00     
primary.xml.gz                                                               | 1.9 MB     00:00     
rhel-i386-server-5                                             5154/5154
rhel5-i386-custom                                                            | 1.2 kB     00:00     
primary.xml.gz                                                               | 1.3 kB     00:00     
rhel5-i386-custom                                              2/2
rhn-tools-rhel-i386-server-5                                                 | 1.2 kB     00:00     
primary.xml.gz                                                               |  29 kB     00:00     
rhn-tools-rhel-i386-server-5                                   385/385
Error: Cannot retrieve repository metadata (repomd.xml) for repository: redhat-rhn-proxy-5.2-server-i386-5. Please verify its path and try again
[root@rhnproxy yum]# 

On my Satellite:
[root@satellite rhn]# cat repomd_updateinfo.xml-135 
<?xml version="1.0" encoding="UTF-8"?>
<updates>
[root@satellite rhn]# 

Same problem again - incomplete file!
That's why the missing repomd.xml (repomd.xml-135) will never generated.

And the strange file /var/cache/rhn/repomd-errata/1051 for errata "RHEA-2009:0273" (Errata ID 1051) is on my Satellite again!
Comment 10 Stefan Kutzke 2009-03-06 04:51:03 EST
Created attachment 334274 [details]
Errata ID 1051 Screenshiot

View of /var/cache/repomd-errata/1051 with Midnight Commander - looks strange
Comment 11 Stefan Kutzke 2009-03-06 04:52:46 EST
Created attachment 334275 [details]
Errata ID 1050 Screenshiot

View of /var/cache/repomd-errata/1050 with Midnight Commander in comparison - looks okay

Note You need to log in before you can comment on or make changes to this bug.