Bug 487318 - sat installer, skip selinux test not working.. not in --help
sat installer, skip selinux test not working.. not in --help
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
wes hayutin
na
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-02-25 08:58 EST by wes hayutin
Modified: 2009-09-10 16:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-02-25 08:58:38 EST
Description of problem:

[root@rlx-3-18 iso]# ./install.pl --answer-file=/root/answers.txt
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/answers.txt.
* Performing pre-install checks.
SELinux should be in Permissive or Enforcing mode for your RHN Satellite
to install and function properly.  Run /usr/sbin/getenforce to see your
current mode.  If you are certain that you are not in Disabled mode or
you want to install in Disabled anyway, re-run the installer with the
flag --skip-selinux-test.  Please see the documentation for steps needed
to enable SELinux post install.


[root@rlx-3-18 iso]# ./install.pl --answer-file=/root/answers.txt --skip-selinux-test.
* Starting the Red Hat Network Satellite installer.
Unknown option: skip-selinux-test.
Comment 1 Devan Goodwin 2009-04-02 09:54:45 EDT
By test not working I assume your box was actually in Permissive or Enforcing, but the check still failed?
Comment 2 Devan Goodwin 2009-04-02 10:01:11 EDT
Message appears to be different right now:

[root@satellite satiso]# ./install.pl --answer-file=/root/spacewalkfiles/answers-satellite.txt  --skip-db-install 
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/spacewalkfiles/answers-satellite.txt.
* Performing pre-install checks.
SELinux must be in Disabled or Permissive mode for your RHN Satellite to
install and function properly.  Run /usr/sbin/getenforce to see your current
mode.  If you are certain that you are not in Enforcing mode you can re-run
the installer with the flag --skip-selinux-test.

[root@satellite satiso]# getenforce
Enforcing
[root@satellite satiso]# setenforce 0
[root@satellite satiso]# getenforce
Permissive
[root@satellite satiso]# ./install.pl --answer-file=/root/spacewalkfiles/answers-satellite.txt  --skip-db-install 
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/spacewalkfiles/answers-satellite.txt.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.

install.pl --help shows:

    --skip-selinux-test
            Do not check if SELinux is Permissive or Disabled. RHN Satellite
            is not currently supported on selinux 'Enforcing' enabled
            systems. See http://kbase.redhat.com/faq/FAQ_49_6086.shtm for
            more information.

Usage appears to work, so looks like this got fixed somewhere, probably in spacewalk.git commit 4793a3b44a71686f1011ff007e87b8ea7cb8c118.
Comment 3 wes hayutin 2009-04-06 15:33:22 EDT
yup.. 
in 4/3 build
  --skip-selinux-test
            Do not check if SELinux is Permissive or Disabled. RHN Satellite
            is not currently supported on selinux 'Enforcing' enabled
            systems. See http://kbase.redhat.com/faq/FAQ_49_6086.shtm for
            more information.


verified
Comment 5 Tomas Lestach 2009-09-07 11:15:27 EDT
Checking on RHEL5 with disabled selinux ...

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.4 (Tikanga)
[root@xen50 ~]# getenforce 
Disabled
[root@xen50 ~]# <path>/Satellite-5.3.0-RHEL5-re20090820.1-x86_64/install.pl --disconnected
* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
Red Hat recommends SELinux be configured in either Permissive or Enforcing
mode for your RHN Satellite installation.  Run /usr/sbin/getenforce to see your
current mode.  If you wish to run in Disabled mode, re-run the installer with
the flag --skip-selinux-test.  When you install while SELinux is disabled and
want to enable SELinux later, run /usr/sbin/spacewalk-selinux-enable once
you've enabled SELinux, to run the post-installation steps which would
otherwise be run by the installer.
# <path>/Satellite-5.3.0-RHEL5-re20090820.1-x86_64/install.pl --disconnected --skip-selinux-test
* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
...

--skip-selinux-test option works as expected

Stage validated -> RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 16:33:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.