This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 487323 - yum-builddep fails on start
yum-builddep fails on start
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
9
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 09:05 EST by Pavel Alexeev
Modified: 2014-01-21 18:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 14:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2009-02-25 09:05:48 EST
Description of problem:
# LANG=C yum-builddep subversion-1.5.4-3.src.rpm
Excluding Packages in global exclude list
Finished
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 4ebfc273
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 147, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 42, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 65, in main
    self.get_build_deps()
  File "/usr/bin/yum-builddep", line 112, in get_build_deps
    srpms.append(yum.packages.YumLocalPackage(self.ts, arg))
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 1466, in __init__
    'Could not open local rpm file: %s' % self.localpath
yum.Errors.MiscError: Could not open local rpm file: subversion-1.5.4-3.src.rpm


Strange error, because it is normal file on regular filesystem:
# ls -l subversion-1.5.4-3.src.rpm 
-rw-r--r-- 1 pasha users 6755184 Окт 31 03:42 subversion-1.5.4-3.src.rpm

Version-Release number of selected component (if applicable):
# rpm -qa | egrep 'rpm|yum'
rpmdevtools-7.0-1.fc9.noarch
yum-metadata-parser-1.1.2-9.fc9.i386
yum-utils-1.1.19-1.fc9.noarch
rpm-4.4.2.3-3.fc9.i386
rpm-build-4.4.2.3-3.fc9.i386
yum-3.2.21-2.fc9.noarch
redhat-rpm-config-9.0.2-1.fc9.noarch
rpm-libs-4.4.2.3-3.fc9.i386
rpm-python-4.4.2.3-3.fc9.i386
Comment 1 seth vidal 2009-02-27 14:37:13 EST
run rpm -K -v on that file, please.

The specific problem causing this traceback has been fixed upstream

yum-utils checking: e5f10900eb37c5b92a7198488f5066153954a991
Comment 2 Pavel Alexeev 2009-02-27 14:56:31 EST
(In reply to comment #1)
> run rpm -K -v on that file, please.
No problem:
# LANG=C rpm -K -v subversion-1.5.4-3.src.rpm 
subversion-1.5.4-3.src.rpm:
    Header V3 DSA signature: NOKEY, key ID 4ebfc273
    Header SHA1 digest: OK (067e94e73a2634aeda909621fa14d4b12cbc24d1)
    MD5 digest: OK (32ee7d18927a48dd825d1730aaa4676a)
    V3 DSA signature: NOKEY, key ID 4ebfc273

File from official Fedora repository.

> The specific problem causing this traceback has been fixed upstream
> yum-utils checking: e5f10900eb37c5b92a7198488f5066153954a991
Is there update in our repos? May be in tesing?
Comment 3 seth vidal 2009-02-27 15:03:22 EST
I don't think a yum-utils update has been pushed, yet.

And if you import the gpg key for fedora 10 into your rpmdb the error will stop for you, too.
Comment 4 Pavel Alexeev 2009-02-27 15:09:50 EST
(In reply to comment #3)
> I don't think a yum-utils update has been pushed, yet.
Can you provide link on koji build that should provide fix?

> And if you import the gpg key for fedora 10 into your rpmdb the error will stop
> for you, too.
Hm... Why it is not done automaticaly by example how yum do it? What I must do for that?
Comment 5 seth vidal 2009-02-27 15:19:50 EST
it'll be in the next upstream yum-utils release. Right now, not, yet, out.
Comment 6 Pavel Alexeev 2009-02-27 15:32:17 EST
Okay, wait.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.