Bug 487343 - pulseaudio-0.9.15-2.test3.fc11.x86_64: daemon fails to start....
pulseaudio-0.9.15-2.test3.fc11.x86_64: daemon fails to start....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 487437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 10:14 EST by Tom London
Modified: 2009-02-26 22:43 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 19:39:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of "pulseaudio --start" (33.24 KB, text/plain)
2009-02-25 10:14 EST, Tom London
no flags Details
output of "strace -f strace --start" (73.16 KB, text/plain)
2009-02-25 15:43 EST, Tom London
no flags Details
Proposed patch for the linking problem. (552 bytes, patch)
2009-02-26 12:35 EST, Tomislav Vujec
no flags Details | Diff

  None (edit)
Description Tom London 2009-02-25 10:14:06 EST
Created attachment 333169 [details]
strace output of "pulseaudio --start"

Description of problem:
Updating to pulseaudio-0.9.15-2.test3.fc11.x86_64, daemon fails to start:

[tbl@tlondon ~]$ pulseaudio -vvvvvvvvvvvv --start
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
D: main.c: Started as real root: no, suid root: yes
I: main.c: We're in the group 'pulse-rt', allowing high-priority scheduling.
I: main.c: RLIMIT_RTPRIO is set to 20, allowing real-time scheduling.
I: main.c: RLIMIT_NICE is set to 40, allowing high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
D: main.c: Can realtime: yes, can high-priority: yes
I: main.c: Giving up CAP_NICE
D: main.c: Can realtime: yes, can high-priority: yes
E: main.c: Daemon startup failed.
[tbl@tlondon ~]$ 

Strace attached.  Looks like pulseaudio.mo (at least en, en_US, ...) is missing.  Not sure if something else is at issue...

open("/usr/share/locale/locale.alias", O_RDONLY) = 7
--- SIGCHLD (Child exited) @ 0 (0) ---
fstat(7, {st_mode=S_IFREG|0644, st_size=2512, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f27f6241000
read(7, "# Locale name alias data base.\n# "..., 4096) = 2512
read(7, ""..., 4096)                    = 0
close(7)                                = 0
munmap(0x7f27f6241000, 4096)            = 0
open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/pulseaudio.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en_US.utf8/LC_MESSAGES/pulseaudio.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en_US/LC_MESSAGES/pulseaudio.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en.UTF-8/LC_MESSAGES/pulseaudio.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/pulseaudio.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/pulseaudio.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
ioctl(2, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
write(2, "E: main.c: \33[1;31mDaemon startup "..., 45E: main.c: Daemon startup failed.
) = 45
write(4, "x"..., 1)   


Reverting back to pulseaudio-0.9.15-0.test2.fc11.x86_64 makes it "work for me".

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-2.test3.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-02-25 15:43:09 EST
Created attachment 333224 [details]
output of "strace -f strace --start"

Another strace run, this time with "-f" to trace children processes.
Comment 2 David Nielsen 2009-02-25 17:04:01 EST
It doesn't start for me either, maybe this will help:

[david@dawkins SRPMS]$ pulseaudio -vvv
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
D: main.c: Started as real root: no, suid root: yes
I: main.c: PolicyKit refuses acquire-high-priority privilege.
N: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
N: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operationen er ikke tilladt
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operationen er ikke tilladt
D: main.c: Can realtime: no, can high-priority: no
D: main.c: Can realtime: no, can high-priority: no
I: main.c: This is PulseAudio 0.9.15-test3
D: main.c: Compilation host: x86_64-unknown-linux-gnu
D: main.c: Compilation CFLAGS: -ggdb -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: main.c: Running on host: Linux x86_64 2.6.29-0.148.rc6.fc11.x86_64 #1 SMP Tue Feb 24 10:36:50 EST 2009
D: main.c: Found 2 CPUs.
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Running in valgrind mode: no
D: main.c: Optimized build: no
I: main.c: Machine ID is f1ea346d2c3c1247de7b385c498af645.
I: main.c: Using runtime directory /home/david/.pulse/f1ea346d2c3c1247de7b385c498af645:runtime.
I: main.c: Using state directory /home/david/.pulse.
I: main.c: Running in system mode: no
W: pid.c: Stale PID file, overwriting.
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: rtclock.c: Timer slack set to 50 us.
D: rtclock.c: Setting timer slack to 500000 us.
D: memblock.c: Using shared memory pool with 1024 slots of size 64,0 KiB each, total size is 64,0 MiB, maximum usable slot size is 65472
I: module-device-restore.c: Sucessfully opened database file '/home/david/.pulse/f1ea346d2c3c1247de7b385c498af645:device-volumes.x86_64-unknown-linux-gnu.gdbm'.
I: module.c: Loaded "module-device-restore" (index: #0; argument: "").
I: module-stream-restore.c: Sucessfully opened database file '/home/david/.pulse/f1ea346d2c3c1247de7b385c498af645:stream-volumes.x86_64-unknown-linux-gnu.gdbm'.
I: module.c: Loaded "module-stream-restore" (index: #1; argument: "").
I: module-card-restore.c: Sucessfully opened database file '/home/david/.pulse/f1ea346d2c3c1247de7b385c498af645:card-database.x86_64-unknown-linux-gnu.gdbm'.
I: module.c: Loaded "module-card-restore" (index: #2; argument: "").
I: module.c: Loaded "module-augment-properties" (index: #3; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib64/pulse-0.9.15/modules/module-hal-detect.so': success
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Loading module-alsa-card with arguments 'device_id=0 name=usb_device_41e_4058_noserial_if2_sound_card_0 card_name=alsa_card.usb_device_41e_4058_noserial_if2_sound_card_0 tsched=1'
pulseaudio: symbol lookup error: /usr/lib64/pulse-0.9.15/modules/libalsa-util.so: undefined symbol: pa_dbus_bus_get
Comment 3 Tom London 2009-02-25 17:22:31 EST
Yeah, I get that too.

Does pa_dbus_bus_get come from libdbus_util.so ?

[root@tlondon modules]# readelf -a libdbus-util.so | grep pa_dbus_bus_get
    49: 0000000000002a74   490 FUNC    GLOBAL DEFAULT   11 pa_dbus_bus_get
[root@tlondon modules]#
Comment 4 antonio montagnani 2009-02-25 18:52:10 EST
*** Bug 487437 has been marked as a duplicate of this bug. ***
Comment 5 antonio montagnani 2009-02-25 18:52:47 EST
also for i386
Comment 6 Mike Chambers 2009-02-25 22:16:55 EST
Getting samething here as well.
Comment 7 Tomislav Vujec 2009-02-26 11:32:52 EST
Same thing here on i586. It looks like a linking problem. This is the line from build log (downloaded from koji.fedoraproject.org) for the current version (0.9.15-test2):

libtool: link: gcc -shared  .libs/libalsa_util_la-alsa-util.o .libs/libalsa_util_la-alsa-sink.o .libs/libalsa_util_la-alsa-source.o .libs/libalsa_util_la-hal-util.o .libs/libalsa_util_la-reserve.o .libs/libalsa_util_la-reserve-wrap.o   -Wl,-rpath -Wl,/builddir/build/BUILD/pulseaudio-0.9.15-test3/src/.libs -L/builddir/build/BUILD/pulseaudio-0.9.15-test3/src/.libs -lasound ./.libs/libpulsecore-0.9.15.so -lltdl -lsamplerate -lsndfile -lspeexdsp -loil-0.3 /builddir/build/BUILD/pulseaudio-0.9.15-test3/src/.libs/libpulse.so ./.libs/libpulsecommon-0.9.15.so ./.libs/libpulse.so /builddir/build/BUILD/pulseaudio-0.9.15-test3/src/.libs/libpulsecommon-0.9.15.so -lX11 -lSM -lICE -lXtst -lwrap -lasyncns -L/lib -lhal -ldbus-1 -lcap -lgdbm -lrt -ldl -lm  -pthread   -pthread -Wl,-soname -Wl,libalsa-util.so -o .libs/libalsa-util.so

And this is the same for the last working version (0.9.15-test2):

libtool: link: gcc -shared  .libs/libalsa_util_la-alsa-util.o .libs/libalsa_util_la-alsa-sink.o .libs/libalsa_util_la-alsa-source.o .libs/libalsa_util_la-hal-util.o   -Wl,-rpath -Wl,/builddir/build/BUILD/pulseaudio-0.9.15-test2/src/.libs -Wl,-rpath -Wl,/usr/lib/pulse-0.9.15/modules/ -L/builddir/build/BUILD/pulseaudio-0.9.15-test2/src/.libs -lasound ./.libs/libpulsecore-0.9.15.so ./.libs/libpulsecommon-0.9.15.so ./.libs/libpulse.so -L/lib -lhal ./.libs/libdbus-util.so -ldbus-1 /builddir/build/BUILD/pulseaudio-0.9.15-test2/src/.libs/libpulsecore-0.9.15.so -lltdl -lsamplerate -lsndfile -lspeexdsp -loil-0.3 /builddir/build/BUILD/pulseaudio-0.9.15-test2/src/.libs/libpulse.so /builddir/build/BUILD/pulseaudio-0.9.15-test2/src/.libs/libpulsecommon-0.9.15.so -lX11 -lSM -lICE -lwrap -lasyncns -lcap -lgdbm -lrt -ldl -lm  -pthread   -pthread -Wl,-soname -Wl,libalsa-util.so -o .libs/libalsa-util.so

You'll notice that the libdbus-util.so is missing in the former, which causes report on missing symbol pa_dbus_bus_get.
Comment 8 Tomislav Vujec 2009-02-26 12:35:48 EST
Created attachment 333362 [details]
Proposed patch for the linking problem.

After introducing "HAVE_DBUS" flag, libdbus-util got lost in linking dependencies for libalsa-util.
Comment 9 Lennart Poettering 2009-02-26 19:39:04 EST
Should be fixed in 0.9.15-3, which is building in koji right now.
Comment 10 Mike Chambers 2009-02-26 22:43:45 EST
Confirmed, the fix does work and sound is restored.  Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.