Bug 487351 - Proxy deactivation fails
Proxy deactivation fails
Status: CLOSED DUPLICATE of bug 489395
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
wes hayutin
: Regression
Depends On:
Blocks: 456996 456999 486126
  Show dependency treegraph
 
Reported: 2009-02-25 11:01 EST by Miroslav Suchý
Modified: 2009-08-25 15:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 14:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-02-25 11:01:58 EST
Description of problem:
When I try to deactivate proxy, I get error. I seems that problem, which already happen in 480126 strikes again.

Version-Release number of selected component (if applicable):
sat530

How reproducible:
always

Steps to Reproduce:
1. register machine (proxy) to satellite with proxy channel
2. install package spacewalk-proxy-installer-0.5.14-1 or later
3. /usr/bin/rhn-proxy-activate --server=<rhn-parent> --ca-cert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT --version="5.3" --non-interactive
4. /usr/bin/rhn-proxy-activate --server=<rhn-parent> --ca-cert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT --deactivate --non-interactive
  
Actual results:
[root@dhcp77-189 ~]# /usr/bin/rhn-proxy-activate --server=dhcp77-206.rhndev.redhat.com --ca-cert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT --deactivate --non-interactive
API version: 0.4
ERROR: connection issues? <ProtocolError for dhcp77-206.rhndev.redhat.com /rpc/api: 500 Internal Server Error>

Expected results:
no error and proxy deactivate

Additional info:
Relevant lines from catalina.out
Caused by: org.hibernate.StaleStateException: Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1
        at org.hibernate.jdbc.Expectations$BasicExpectation.checkBatched(Expectations.java:61)
        at org.hibernate.jdbc.Expectations$BasicExpectation.verifyOutcome(Expectations.java:46)
        at org.hibernate.jdbc.NonBatchingBatcher.addToBatch(NonBatchingBatcher.java:24)
        at org.hibernate.persister.entity.AbstractEntityPersister.delete(AbstractEntityPersister.java:2520)
        at org.hibernate.persister.entity.AbstractEntityPersister.delete(AbstractEntityPersister.java:2697)
        at org.hibernate.action.EntityDeleteAction.execute(EntityDeleteAction.java:74)
        at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:250)
        at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:234)
        at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:146)
        at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:298)
        at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:27)
        at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1000)
        at com.redhat.rhn.common.db.datasource.CachedStatement.stealConnection(CachedStatement.java:853)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:441)
        ... 47 more
2009-02-25 09:54:16,882 [TP-Processor3] ERROR com.redhat.rhn.frontend.xmlrpc.BaseHandler - Caused by:
com.redhat.rhn.common.hibernate.HibernateRuntimeException: HibernateException executing CachedStatement
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:469)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:431)
        at com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:269)
        at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:33)
        at com.redhat.rhn.manager.system.SystemManager.executeWriteMode(SystemManager.java:1293)
        at com.redhat.rhn.manager.system.SystemManager.deactivateProxy(SystemManager.java:1281)
        at com.redhat.rhn.frontend.xmlrpc.proxy.ProxyHandler.deactivateProxy(ProxyHandler.java:118)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at com.redhat.rhn.frontend.xmlrpc.BaseHandler.invoke(BaseHandler.java:106)
        at redstone.xmlrpc.XmlRpcDispatcher.dispatch(XmlRpcDispatcher.java:123)
        at com.redhat.rhn.frontend.xmlrpc.RhnXmlRpcServer.execute(RhnXmlRpcServer.java:53)
        at com.redhat.rhn.frontend.xmlrpc.XmlRpcServlet.doPost(XmlRpcServlet.java:162)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
Comment 1 Brad Buckingham 2009-04-01 14:49:44 EDT
After further investigation, this issue appears to be a duplicate of bug 489395 which is currently ON_QA.  As a result, marking this one as a duplicate.

*** This bug has been marked as a duplicate of bug 489395 ***
Comment 2 John Matthews 2009-08-03 12:05:15 EDT
Marking CloseValid in WhiteBoard.

Note You need to log in before you can comment on or make changes to this bug.