Bug 487390 - system-config-kickstart anaconda-ks.cfg crash
system-config-kickstart anaconda-ks.cfg crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 517554 519146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 14:37 EST by Chris
Modified: 2009-08-25 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 14:21:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2009-02-25 14:37:16 EST
Description of problem:

system-config-kickstart crash

Version-Release number of selected component (if applicable):
[root@linux ~]# uname -a
Linux linux 2.6.27.15-170.2.24.fc10.i686 #1 SMP Wed Feb 11 23:58:12 EST 2009 i686 athlon i386 GNU/Linux
[root@linux ~]# rpm -q system-config-kickstart
system-config-kickstart-2.7.20-1.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. [root@linux ~]# system-config-kickstart anaconda-ks.cfg
2. 
3.
  
Actual results:
system-config-kickstart crashes with...

Component: system-config-kickstart
Summary: TB1b31bf82 basic.py:238:applyKickstart:ValueError: list.index(x): x not in list

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 315, in on_activate_open
    self.applyKickstart()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 339, in applyKickstart
    self.basic_class.applyKickstart()
  File "/usr/share/system-config-kickstart/basic.py", line 238, in applyKickstart
    self.timezone_combo.list.select_item(self.timezone_list.index(self.ks.timezone.timezone))
ValueError: list.index(x): x not in list

Local variables in innermost frame:
lang: Italian (Switzerland)
ksLang: en_US
self: <basic.basic instance at 0xb79876ec>

Expected results:
Should allow editing of anaconda-ks.cfg

Additional info:
Comment 1 Chris Lumens 2009-04-17 14:21:51 EDT
This will be fixed in the next build of system-config-kickstart.  Thanks for the bug report.  I'm planning on doing an update release for F-10 in the near future too.
Comment 2 Chris Lumens 2009-08-14 13:41:44 EDT
*** Bug 517554 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-08-25 10:16:00 EDT
*** Bug 519146 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.