Bug 487410 - Cannot rebuild metacity-2.24.0-2.fc10.src.rpm with mock (i686 target)
Cannot rebuild metacity-2.24.0-2.fc10.src.rpm with mock (i686 target)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 15:54 EST by Massimiliano
Modified: 2014-06-18 05:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 11:32:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that includes in the 'metacity.spec' file the missing 'dbus-devel' dependency (387 bytes, patch)
2009-04-19 12:11 EDT, Massimiliano
no flags Details | Diff

  None (edit)
Description Massimiliano 2009-02-25 15:54:09 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020410 Fedora/3.0.6-1.fc10 Firefox/3.0.6

I cannot rebuild metacity-2.24.0-2.fc10.src.rpm with mock (i686 target). The first reason is that the package dbus-devel is required, but it's not installed automatically by yum. So I have installed dbus-devel into the chroot manually. After the dbus-devel installation, there's another problem (from mock build.log):

Generating and caching the translation database
Merging translations into metacity.desktop.
LC_ALL=C /usr/bin/intltool-merge -s -u -c ../po/.intltool-merge-cache ../po metacity.schemas.in metacity.schemas
Found cached translation database
Merging translations into metacity.schemas.
LC_ALL=C /usr/bin/intltool-merge -d -u -c ../po/.intltool-merge-cache ../po metacity-wm.desktop.in metacity-wm.desktop
Found cached translation database
Merging translations into metacity-wm.desktop.
LC_ALL=C /usr/bin/intltool-merge -x -u /tmp 50-metacity-desktop-key.xml.in 50-metacity-desktop-key.xml
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/auto/XML/Parser/Expat/Expat.so: undefined symbol: Perl_pad_sv
make[4]: *** [50-metacity-desktop-key.xml] Error 127
make[4]: Leaving directory `/builddir/build/BUILD/metacity-2.24.0/src'
make[3]: Leaving directory `/builddir/build/BUILD/metacity-2.24.0/src'
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[2]: Leaving directory `/builddir/build/BUILD/metacity-2.24.0/src'
make[1]: Leaving directory `/builddir/build/BUILD/metacity-2.24.0'
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.boqj3E (%build)
    Bad exit status from /var/tmp/rpm-tmp.boqj3E (%build)
RPM build errors:
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target i686 --nodeps builddir/build/SPECS/metacity.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.5/site-packages/mock/util.py", line 317, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target i686 --nodeps builddir/build/SPECS/metacity.spec']
LEAVE do --> EXCEPTION RAISED


Reproducible: Always

Steps to Reproduce:
1. mock --rebuild metacity-2.24.0-2.fc10.src.rpm
Actual Results:  
EXCEPTION RAISED, BUILD FAILS

Expected Results:  
BUILD SUCCESS
Comment 1 Massimiliano 2009-04-19 12:11:51 EDT
Created attachment 340239 [details]
Patch that includes in the 'metacity.spec' file the missing 'dbus-devel' dependency

Please, forget the second error: it seems to be related to my i686 version of the perl rpm (many of my packages are re-builded for my platform). I don't know why: I'm trying to understand.
Still remains the first problem: but it is a simple missing dependency. Applying the patch (see the attachment) works perfectly.
Comment 2 Owen Taylor 2009-11-16 11:32:27 EST
dbus-devel is in the current F12 metacity.spec (was added by mclasen December 2008) and presumably the F11 one as well. 

(I don't actually know *why* dbus-devel is needed. Metacity doesn't use D-Bus directly, so it seems like a missing dependency in some other devel package... but I'm going to ignore that.)

Note You need to log in before you can comment on or make changes to this bug.