Bug 487453 - RSIBreak in Fedora 10 with all updates-testing installed leaks tons of memory
RSIBreak in Fedora 10 with all updates-testing installed leaks tons of memory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rsibreak (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 23:21 EST by Artem S. Tashkinov
Modified: 2009-03-04 11:21 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.9.0-10.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 11:21:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file patch (1.19 KB, patch)
2009-02-26 09:44 EST, Artem S. Tashkinov
no flags Details | Diff
rsibreak patch (505 bytes, patch)
2009-02-26 09:45 EST, Artem S. Tashkinov
no flags Details | Diff

  None (edit)
Description Artem S. Tashkinov 2009-02-25 23:21:00 EST
Fedora 10 installation with all updates and all updates-testing.

KWin compositing effects are turned off.

rsibreak in a matter of one hour eats up to 250MB of RAM.
Comment 1 Thomas Janssen 2009-02-26 05:11:10 EST
Must be some updates-testing problem. I had rsibreak running here (KDE 4.2 just updates) yesterday for 12 hours and today and it was always that:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
28072 thomas    20   0  338m  16m  11m S  0.3  0.6   0:01.76 rsibreak

IIRC there are two updates to kde in updates-testing. One is kdelibs. You could try and move back to the old Version to see if it fixes it.
Comment 2 Rex Dieter 2009-02-26 09:12:33 EST
From recent #fedora-kde and #kde-devel discussions, looks like this upstream commit/patch should help:
http://websvn.kde.org/trunk/extragear/utils/rsibreak/src/graywidget.cpp?r1=919136&r2=932376
Comment 3 Rex Dieter 2009-02-26 09:13:16 EST
please provide what version of rsibreak you're using.

rpm -q rsibreak
Comment 4 Artem S. Tashkinov 2009-02-26 09:44:45 EST
Created attachment 333333 [details]
spec file patch
Comment 5 Artem S. Tashkinov 2009-02-26 09:45:28 EST
Created attachment 333334 [details]
rsibreak patch
Comment 6 Artem S. Tashkinov 2009-02-26 09:46:54 EST
The patch to KDE svn has been commited.

http://websvn.kde.org/trunk/extragear/utils/rsibreak/src/graywidget.cpp?r1=919136&r2=932376

Please, close this bug report as soon as Fedora's patched rsibreak is available.
Comment 7 Rex Dieter 2009-02-26 09:48:09 EST
thanks!
Comment 8 Roland Wolters 2009-02-26 14:29:16 EST
Rex, are you working on that, or should I initialize the build?
Comment 9 Rex Dieter 2009-02-26 14:33:22 EST
nothing on my end (yet), my todo queue is pretty deep at the moment.
Comment 10 Roland Wolters 2009-02-26 14:40:12 EST
Ok, I'm on it, will close the bug via koji/update-system.
Comment 11 Fedora Update System 2009-02-26 15:48:33 EST
rsibreak-0.9.0-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rsibreak-0.9.0-10.fc10
Comment 12 Fedora Update System 2009-02-27 22:25:55 EST
rsibreak-0.9.0-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rsibreak'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2172
Comment 13 Fedora Update System 2009-03-04 11:21:27 EST
rsibreak-0.9.0-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.