Bug 487522 - debuginfo-install does not honor the epoch number
debuginfo-install does not honor the epoch number
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 491145 512388 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 10:13 EST by Michal Nowak
Modified: 2014-01-21 18:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 15:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-02-26 10:13:33 EST
debuginfo-install does not honor the epoch number:

(On the same system.)

Not able to install via debuginfo-install:
=======================================================

newman@dhcp-lab-124 ~ $ sudo debuginfo-install mc-debuginfo
Loaded plugins: dellsysidplugin2, refresh-packagekit
enabling rawhide-debuginfo
Reading repository metadata in from local files
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
No debuginfo packages available to install
newman@dhcp-lab-124 ~ $ sudo debuginfo-install gedit-debuginfo
Loaded plugins: dellsysidplugin2, refresh-packagekit
enabling rawhide-debuginfo
Reading repository metadata in from local files
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
No debuginfo packages available to install

Able to install via yum:
=======================================================
newman@dhcp-lab-124 ~ $ sudo yum install mc-debuginfo
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package mc-debuginfo.x86_64 1:4.6.2-8.pre1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================
 Package                                Arch                             Version                                       Repository                                   Size
=========================================================================================================================================================================
Installing:
 mc-debuginfo                           x86_64                           1:4.6.2-8.pre1.fc11                           rawhide-debuginfo                           1.3 M

Transaction Summary
=========================================================================================================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.3 M
Is this ok [y/N]: 
Exiting on user Command
Complete!
newman@dhcp-lab-124 ~ $ sudo yum install gedit-debuginfo
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package gedit-debuginfo.x86_64 1:2.25.7-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================
 Package                                   Arch                             Version                                    Repository                                   Size
=========================================================================================================================================================================
Installing:
 gedit-debuginfo                           x86_64                           1:2.25.7-1.fc11                            rawhide-debuginfo                           1.5 M

Transaction Summary
=========================================================================================================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.5 M
Is this ok [y/N]: 
Exiting on user Command
Complete!

--

    1:2.25.7-1.fc11

`---^----------------(what I call epoch)
Comment 1 Michal Nowak 2009-05-25 07:47:34 EDT
*** Bug 491145 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2009-06-09 07:39:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michal Nowak 2009-08-19 07:24:50 EDT
*** Bug 512388 has been marked as a duplicate of this bug. ***
Comment 4 seth vidal 2009-10-09 15:15:26 EDT
I think the confusion here stems from what you're passing to each one:

for yum you tell it what pkg you want, complete with the debuginfo name

for debuginfo-install you tell it the name of the package you want the debuginfo installed for.

so:

debuginfo-install gedit
is equivalent to:
yum --enablerepo='*debuginfo' gedit-debuginfo

see what I mean?

and I think this has nothing to do with epoch.

Note You need to log in before you can comment on or make changes to this bug.