Bug 487564 - ks pv host, after kickstarting a box as a pv host, ready to install pv guest from satellite
ks pv host, after kickstarting a box as a pv host, ready to install pv guest ...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
na
:
: 449127 (view as bug list)
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-02-26 13:41 EST by wes hayutin
Modified: 2014-05-09 06:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 06:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-02-26 13:41:17 EST
Description of problem:

Currently after kickstarting a box as a pv host a user has to an extra step to get the box in a condition where one can immediately use satellite to provision pv guests. 

Depending on the version of satellite and build of 5.3 that may include.
1. giving a virt entitlement
2. installing additional rpms

I think the assumption should be if a customer uses satellite to kickstart a pvhost, they intend to use satellite to provision the guests on that system.  Of course the user can always modify the ks profile, so we're talking default config here.

So our default kickstart profile for a pv host should include.
1. virt entitlement, provisioning entitlement 
2. kernel-xen or other virt enabled kernel (not sure what we're doing w/ kvm)
3. needed packages:
kernel-xen-2.6.18-92.el5
xen-libs-3.0.3-64.el5
xen-3.0.3-64.el5
rhn-virtualization-common-1.0.1-55
rhn-virtualization-host-1.0.1-55
osad? (this was the default behaviour, not sure what we're planning) 

I realize we do some of this today, this bug is to verify that the pv host is ready to install pv guests immediately after provisioning.

I spoke w/ Mike and he agreed.
Comment 1 Partha Aji 2009-05-28 13:08:46 EDT
This should be now fixed as of http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=dbec5dac44262f03bb57ceb812a5e6e9b2a0d6dd

So for virt guest provisioning, the provisioning  entitlement is not required.. So we are not going to be providing that. That being said, the kickstart profile has been updated so that kernel-xen and xen get install for a para host and  the activation key logic has been updated so that rhn-virtualization-host gets installed when any of the virt entitlement gets enabled.. So this should work from the next iso..
Comment 2 Partha Aji 2009-05-29 16:33:52 EDT
Moving to ON_QA
Comment 3 wes hayutin 2009-06-01 13:54:02 EDT
verified 5/29
Comment 4 Brandon Perkins 2009-07-22 14:44:34 EDT
*** Bug 449127 has been marked as a duplicate of this bug. ***
Comment 5 Sayli Karmarkar 2009-07-30 14:08:12 EDT
Looks like it worked because of preservation of system profile which was already registered and given virt entitlement. 

To make sure I registered a rhel4 system and kickstarted it to rhel5 virt host, but the system did not get virt entitlement. System has installed kernel-xen, xen and rhn-virt-host packages and registered to rhn-tools and virt child channels, but virt entitlement is missing. So, failing it.
Comment 8 Clifford Perry 2014-05-09 06:37:39 EDT
We have not addressed this specific bug in over 5 years years. This does not seem to have an active customer case with the bug report either. Closing out as wontfix to clear from backlog. 

Please re-open if you disagree and wish further review.

Cliff

Note You need to log in before you can comment on or make changes to this bug.