Bug 487578 - Grub kernel default not set correctly when kernel-PAE is installed on i686
Grub kernel default not set correctly when kernel-PAE is installed on i686
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 14:43 EST by Craig Robson
Modified: 2009-06-09 01:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 01:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Robson 2009-02-26 14:43:27 EST
I originally was using the non-PAE kernel on my i686.  I then installed the PAE kernel.  When I do this, the PAE kernel does not become the default kernel.

I think this is because DEFAULTKERNEL=kernel in /etc/sysconfig/kernel.

I see the RPM postinstall script updates this to kernel-PAE when transitioning from kernel-smp or kernel-xen.  Should this be automatically updated when changing from kernel to kernel-PAE?
Comment 1 Dave Jones 2009-03-26 14:15:38 EDT
I've committed a change that I think will do the right thing here.

Note You need to log in before you can comment on or make changes to this bug.