Bug 487580 - yum update of postfix breaks email settings
yum update of postfix breaks email settings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 15:10 EST by Dhaval Giani
Modified: 2009-05-21 08:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 08:45:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhaval Giani 2009-02-26 15:10:04 EST
Description of problem:
I just did a yum update, which updated postfix. Doing so completely annihilates the mail settings I had before. My procmail filters no longer work.

Version-Release number of selected component (if applicable):
2:2.5.6-1.fc10

How reproducible:


Steps to Reproduce:
1. yum update
2. start postfix
3.
  
Actual results:

the mail settings which were working earlier (more specifically the filtering done by procmail) is broken.

Expected results:

yum update of postfix should not affect the settings.

Additional info:
Comment 1 Dhaval Giani 2009-02-26 15:13:51 EST
An additional source of information. When I restart postfix and fetchmail, things work. But this is still a bug, a yum update should not break these settings.
Comment 2 Miroslav Lichvar 2009-03-02 05:20:19 EST
Any chance the update installed exim (bug #472756)?
Comment 3 Dhaval Giani 2009-03-02 05:30:43 EST
Doesn't seem to be the case. The yum.log of that update follows,

Feb 27 01:18:07 Updated: e2fsprogs-libs-1.41.4-1.fc10.i386
Feb 27 01:18:07 Updated: 2:gimp-libs-2.6.5-1.fc10.i386
Feb 27 01:18:12 Updated: gvfs-1.0.3-5.fc10.i386
Feb 27 01:18:12 Updated: libgcrypt-1.4.4-1.fc10.i386
Feb 27 01:18:14 Updated: system-config-printer-libs-1.0.15-1.fc10.i386
Feb 27 01:18:33 Updated: 2:gimp-2.6.5-1.fc10.i386
Feb 27 01:18:42 Updated: 2:postfix-2.5.6-1.fc10.i386
Feb 27 01:18:42 Updated: 2:gimp-help-browser-2.6.5-1.fc10.i386
Feb 27 01:18:43 Updated: hal-cups-utils-0.6.19-1.fc10.i386
Feb 27 01:18:43 Updated: libgcrypt-devel-1.4.4-1.fc10.i386
Feb 27 01:18:44 Updated: gvfs-obexftp-1.0.3-5.fc10.i386
Feb 27 01:18:44 Updated: gvfs-fuse-1.0.3-5.fc10.i386
Feb 27 01:18:45 Updated: e2fsprogs-1.41.4-1.fc10.i386
Feb 27 01:18:46 Updated: 1:wpa_supplicant-0.6.4-3.fc10.i386
Feb 27 01:18:53 Updated: gstreamer-plugins-good-0.10.13-1.fc10.i386
Feb 27 01:18:54 Updated: crontabs-1.10-26.fc10.noarch
Feb 27 01:18:54 Updated: 6:kdelibs-common-4.2.0-15.fc10.i386
Feb 27 01:18:55 Updated: xorg-x11-server-common-1.5.3-13.fc10.i386
Feb 27 01:18:55 Installed: 2:postfix-perl-scripts-2.5.6-1.fc10.i386
Feb 27 01:18:56 Updated: system-config-printer-1.0.15-1.fc10.i386
Feb 27 01:18:57 Updated: e2fsprogs-devel-1.41.4-1.fc10.i386
Feb 27 01:18:58 Updated: fontpackages-filesystem-1.20-1.fc10.noarch
Feb 27 01:18:58 Updated: xhtml1-dtds-1.0-20020801.1.2.noarch
Feb 27 01:19:09 Updated: 6:kdelibs-4.2.0-15.fc10.i386
Feb 27 01:19:09 Updated: 6:kdemultimedia-libs-4.2.0-3.fc10.i386
Feb 27 01:19:16 Updated: 6:kdelibs-devel-4.2.0-15.fc10.i386
Feb 27 01:22:59 Updated: 6:kdemultimedia-4.2.0-3.fc10.i386
Feb 27 01:23:01 Updated: xorg-x11-server-Xorg-1.5.3-13.fc10.i386
Feb 27 01:23:02 Updated: anacron-2.3-66.fc10.i386
Feb 27 01:23:03 Updated: 6:kdemultimedia-devel-4.2.0-3.fc10.i386
Feb 27 01:23:03 Updated: rpm-libs-4.6.0-1.fc10.i386
Feb 27 01:23:05 Updated: rpm-4.6.0-1.fc10.i386
Feb 27 01:23:06 Updated: kaffeine-libs-0.8.7-3.fc10.i386
Feb 27 01:23:10 Updated: kaffeine-0.8.7-3.fc10.i386
Feb 27 01:23:11 Updated: rpm-devel-4.6.0-1.fc10.i386
Feb 27 01:23:12 Updated: rpm-build-4.6.0-1.fc10.i386
Feb 27 01:23:13 Updated: rpm-python-4.6.0-1.fc10.i386
Feb 27 01:25:37 Updated: rpm-4.6.0-1.fc10.i386
Comment 4 Miroslav Lichvar 2009-03-02 06:27:54 EST
I don't understand what exactly is wrong. The config files which worked with older postfix didn't work after update, but after postfix restart they do?
Comment 5 Dhaval Giani 2009-03-02 06:37:13 EST
No. I did some checking, and it turns out there was nothing wrong with the configuration files. What happened was the header was getting changed, and those rules which were based on the FROM line failed, since the From line was getting changed to my user.
Comment 6 Miroslav Lichvar 2009-05-21 08:45:04 EDT
Ok, I'm still not sure what when wrong, but I'm assuming it was a problem with configuration and closing this as NOTABUG. Please reopen if you think it should be addressed.

Note You need to log in before you can comment on or make changes to this bug.