Bug 487650 - F10 virt-manager: only offers XEN & QEMU, no KVM => No Paravirt
F10 virt-manager: only offers XEN & QEMU, no KVM => No Paravirt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 04:24 EST by Manfred Knick
Modified: 2009-03-01 06:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 12:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfred Knick 2009-02-27 04:24:11 EST
Description of problem:

Although all the paravirt options are enabled in the current kernel .config,
the Virtual Machine Manager ( <- libvirt ) only offers connections to "XEN" and "QEMU", but not "KVM".

Selecting QEMU, trying to build a new VM, the Paravirt alternative keeps greyed out; only the Full_Virt alternative is offered.


Version-Release number of selected component (if applicable):
kernel 2.6.27.15 (amd64)
VMM 0.6.0


How reproducible:
Always


Steps to Reproduce:
1. Start the Virtual Machine Manager
2. Connect
3. Create a new VM


Actual results:
No Paravirt selectable


Expected results:
Be able to build paravirt. VM's


Additional info:

Cross-checking on my parallel Gentoo (2.6.28.5 ; gcc 4.3.3) installation,
paravirt KVMs work like a charme.
Comment 1 Daniel Berrange 2009-02-27 12:43:56 EST
KVM guets run fullvirtualized kernels, with a number of paravirt drivers (clock, disk, network & balloon) - the kernel config options you enable for 'kvm paravirt' are just refering to turning on PV drivers - the core kernel is still fullvirtualizaed. The 'paravirt' option in virt manager refers to truely paravirt kernels like the Xen PV ABI
Comment 2 Manfred Knick 2009-02-27 13:36:17 EST
(In reply to comment #1)

> KVM guets run fullvirtualized kernels ...
> the core kernel is still fullvirtualizaed. 

Thanks a lot for your speedy distinct clarification!

Is this decision due to KVM hanging on 'root mode',
thus creating an internal conflict
if the kernel is XEN-enabled at the same time?

Just for chance, do you happen to know if this will change in F11
(c.f. recent RedHat decisions to (Qumranet-acquired) KVM in favour over XEN) ?
Comment 3 Manfred Knick 2009-03-01 06:29:57 EST
(In reply to comment #2)
> (In reply to comment #1)

I mis-interpreted your answer.  ;(
Forget about my questions !
Sorry!
- m.

Note You need to log in before you can comment on or make changes to this bug.