Bug 487656 - Read and write size of startup status report buffer is incorrect
Read and write size of startup status report buffer is incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ian Kent
BaseOS QE
:
Depends On:
Blocks: 244117 527375
  Show dependency treegraph
 
Reported: 2009-02-27 05:11 EST by Ian Kent
Modified: 2009-10-06 03:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, autofs reported an incorrect buffer size internally when passing the startup status from the autofs daemon to the parent process. Although no specific consequences of this inaccuracy are known, the buffer size is now reported correctly to avoid any consequences arising in the future.
Story Points: ---
Clone Of:
: 527375 (view as bug list)
Environment:
Last Closed: 2009-09-02 07:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Kent 2009-02-27 05:11:04 EST
Description of problem:
An incorrect buffer size is used when communicating the startup
status internally.

This doesn't appear to result in an actual problem but the code
clearly used an incorrect size. It's worth fixing because we may
end up with seeing this a some future time and waste time trying
to work out what's causing it.
Comment 3 Ian Kent 2009-05-20 23:30:42 EDT
This issue has been fixed in the latest autofs package
autofs-5.0.1-0.rc2.125.
Comment 7 Ruediger Landmann 2009-08-31 00:48:54 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, autofs reported an incorrect buffer size internally when passing the startup status from the autofs daemon to the parent process. Although no specific consequences of this inaccuracy are known, the buffer size is now reported correctly to avoid any consequences arising in the future.
Comment 8 errata-xmlrpc 2009-09-02 07:59:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1397.html

Note You need to log in before you can comment on or make changes to this bug.