Bug 487661 - installation fails with a traceback
installation fails with a traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:f1a2aca54d9ede736...
:
: 487431 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 05:56 EST by Daniel Mach
Modified: 2009-03-05 14:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 14:12:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (44.00 KB, text/plain)
2009-02-27 05:56 EST, Daniel Mach
no flags Details

  None (edit)
Description Daniel Mach 2009-02-27 05:56:04 EST
The following was filed automatically by anaconda:
anaconda 11.5.0.23 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/installclasses/fedora.py", line 81, in productMatches
    if oldprod.startswith(productName):
  File "/usr/lib/anaconda/installclass.py", line 223, in productUpgradable
    return self.productMatches(oldprod) and self.versionMatches(oldver)
  File "/usr/lib/anaconda/partedUtils.py", line 643, in findExistingRootPartitions
    if upgradeany == 1 or self.anaconda.id.instClass.productUpgradable(prod, ver):
  File "/usr/lib/anaconda/upgrade.py", line 163, in findExistingRoots
    rootparts = anaconda.id.diskset.findExistingRootPartitions(upgradeany = upgradeany)
  File "/usr/lib/anaconda/upgrade.py", line 129, in findRootParts
    anaconda.id.rootParts = findExistingRoots(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1322, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'startswith'
Comment 1 Daniel Mach 2009-02-27 05:56:14 EST
Created attachment 333456 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-02-27 10:01:32 EST
*** Bug 487431 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-03-05 14:12:23 EST
This should be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.