Bug 487788 - X crashed on lid close
X crashed on lid close
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 16:32 EST by Bill Nottingham
Modified: 2018-04-11 07:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 11:21:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full Xorg log (71.75 KB, text/plain)
2009-02-27 16:32 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2009-02-27 16:32:13 EST
Created attachment 333542 [details]
Full Xorg log

Description of problem:

Log attached. Not using modesetting at the time.

Backtrace from log:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e9be6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47de2f]
2: /lib64/libc.so.6 [0x7fd7b6793340]
3: /usr/lib64/libdrm_intel.so.1(drm_intel_bo_unpin+0) [0x7fd7b4da5770]
4: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7fd7b4fe6ad1]
5: /usr/lib64/xorg/modules/drivers//intel_drv.so(i830_crtc_dpms_video+0x4a) [0x7fd7b4fe6b5a]
6: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7fd7b4fd1150]
7: /usr/bin/Xorg(xf86DPMSSet+0x76) [0x4a29e6]
8: /usr/bin/Xorg(xf86SaveScreen+0x29) [0x4a3249]
9: /usr/bin/Xorg(dixSaveScreens+0x221) [0x436831]
10: /usr/bin/Xorg(DPMSSet+0xff) [0x47d73f]
11: /usr/lib64/xorg/modules/extensions//libextmod.so [0x7fd7b5f1b03b]
12: /usr/bin/Xorg(Dispatch+0x374) [0x447184]
13: /usr/bin/Xorg(main+0x3c5) [0x42d0e5]
14: /lib64/libc.so.6(__libc_start_main+0xfd) [0x7fd7b677e5ed]
15: /usr/bin/Xorg [0x42c569]

Fatal server error:
Caught signal 11.  Server aborting


Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.6.0-9.fc11.x86_64
xorg-x11-server-Xorg-1.6.0-1.fc11.x86_64
kernel-2.6.29-0.157.rc6.git2.fc11.x86_64

How reproducible:

Happened once. Will try to reproduce later when I'm not in the middle of other things.

Steps to Reproduce:
1. Close lid
2. ...
3. Open lid
  
Actual results:

Hey, where'd my desktop go? Why am I looking at gdm?

Expected results:

Screen lock dialog.
Comment 1 Matěj Cepl 2009-03-03 19:17:19 EST
Yummy!

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e9be6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47de2f]
2: /lib64/libc.so.6 [0x7fd7b6793340]
3: /usr/lib64/libdrm_intel.so.1(drm_intel_bo_unpin+0) [0x7fd7b4da5770]
4: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7fd7b4fe6ad1]
5: /usr/lib64/xorg/modules/drivers//intel_drv.so(i830_crtc_dpms_video+0x4a) [0x7fd7b4fe6b5a]
6: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7fd7b4fd1150]
7: /usr/bin/Xorg(xf86DPMSSet+0x76) [0x4a29e6]
8: /usr/bin/Xorg(xf86SaveScreen+0x29) [0x4a3249]
9: /usr/bin/Xorg(dixSaveScreens+0x221) [0x436831]
10: /usr/bin/Xorg(DPMSSet+0xff) [0x47d73f]
11: /usr/lib64/xorg/modules/extensions//libextmod.so [0x7fd7b5f1b03b]
12: /usr/bin/Xorg(Dispatch+0x374) [0x447184]
13: /usr/bin/Xorg(main+0x3c5) [0x42d0e5]
14: /lib64/libc.so.6(__libc_start_main+0xfd) [0x7fd7b677e5ed]
15: /usr/bin/Xorg [0x42c569]

Fatal server error:
Caught signal 11.  Server aborting
Comment 2 Bill Nottingham 2009-03-03 19:22:17 EST
FYI - I've since opened and closed the lid multiple times without it crashing again.
Comment 3 Adam Jackson 2009-05-08 11:21:13 EDT
Closing as per commentg #2.

Note You need to log in before you can comment on or make changes to this bug.