Bug 487792 - The tool teminates abruptly.
The tool teminates abruptly.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: v4l2-tool (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 16:43 EST by best4ever.bharat
Modified: 2009-03-22 21:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 00:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description best4ever.bharat 2009-02-27 16:43:52 EST
Description of problem:A bug appears.


Version-Release number of selected component (if applicable):
GNOME v4l2-tool 1.0.3


How reproducible:
Almost exactly reproducible.


Steps to Reproduce:
1.open the v4l2-tool GUI (From Applications--> Sound & Video --> v4l2).
2.Click File --> Open Device.
3.Select any of the file from the path /dev/input/by-path/.
4. click Open.
  
Actual results:
The tool exits/terminates with a bug report.

Expected results:
The selected file should be opened.

Additional info:
Comment 1 Parag AN(पराग) 2009-03-02 01:16:13 EST
v4l2-tool is old and not updated since years. v4l2-tool uses only /dev/videoX files.
try opening /dev/video0 in v4l2-tool.
Comment 2 best4ever.bharat 2009-03-22 07:47:47 EDT
/dev/video0 is opened successfully. But then I am not able to understand 'what is the use of this v4l2-tool (except suggesting the name of the driver required for a device)?
Comment 3 Parag AN(पराग) 2009-03-22 21:28:00 EDT
There are few other tabs in v4l2-tool application. If you check them then you will find that v4l2-tool tries to give you internal hardware information of the webcam like 
driver name if your webcam is automatically picked up by any supported kernel module.
card and bus info that you can also find in /sys
driver version of kernel module for your webcam.
Capability values that webcam supports see http://www.thedirks.org/v4l2/v4l2cap.htm
Crop Capability information see ioctl call VIDIOC_CROPCAP to get information like width and height. see http://v4l2spec.bytesex.org/spec/r7771.htm

such that many more information of your webcam.

I really wonder why you see only Suggest Driver tab in v4l2-tool application and not other tabs. Do you see there is any problem of unable to see those tabs Capability,Crop Capability,Input,Query Control,Frame Format,Device info?

Note You need to log in before you can comment on or make changes to this bug.