Bug 487833 - Hal fails to detect hotplugged mice/keyboards in hal-0.5.12-21.20090226git.fc11
Hal fails to detect hotplugged mice/keyboards in hal-0.5.12-21.20090226git.fc11
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 22:43 EST by David Reed
Modified: 2009-09-09 09:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 09:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Reed 2009-02-27 22:43:24 EST
Description of problem:

latest hal doesn't detect/signal hotplug/unplug of usb and bluetooth mice and keyboards. This is a regression that happened between 26 Feb and 27 Feb.

Version-Release number of selected component (if applicable):

hal
Arch       : i586
Version    : 0.5.12
Release    : 21.20090226git.fc11


How reproducible:

Using Fedora 11 alpha upgraded as of 27 Feb with bluetooth or usb mouse, plug or pair a detachable mouse to the laptop.  dmesg shows that the usb device is added or dropped.  "lshal -m" does not.  As a result, evdev doesn't hear about mouse, and mouse is not usable.



Steps to Reproduce:
1. yum update to latest packages as of 27 Feb.
2. plug in or pair device
3.
  
Actual results:

mouse detected, udev processes it, dmesg shows it, but lshal -m doesn't and mouse is not usable.

Expected results:

lshal -m used to show it, mouse would be usable in Xorg


Additional info:
Comment 1 Richard Hughes 2009-02-28 04:59:49 EST
Th udev install path is wrong, and was changed upstream. I'll patch it in the rpm and send the fix upstream.

Should be fixed in http://koji.fedoraproject.org/koji/taskinfo?taskID=1208230

Richard.
Comment 2 Scott Glaser 2009-04-23 14:26:38 EDT
David
Have you tried the link in comment 1 or have you updated your your Rawhide installation? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using? You can obtain that information by performing: rpm -qa hal\*


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 David Reed 2009-04-23 15:51:15 EDT
A worse problem in a separate subsystem happened with a rawhide update after I reported this, and I had to give up testing F11 on that machine for a while since it failed to even complete booting.

I will see if I can reinstall and test the latest F11 on that machine in the next few days.
Comment 4 Bug Zapper 2009-06-09 07:44:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 David Reed 2009-06-30 11:47:52 EDT
In Fedora 11 I no longer experience this bug on the machine and configuration where I demonstrated it.  I'd be happy if it were closed.
Comment 6 Scott Glaser 2009-09-09 09:16:46 EDT
David,

Based on comment 5 I am going to close this bug.  If you experience these symptoms again please file a new bug against the applicable component.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.