Bug 487837 - mozilla-plugin.pc doesn't add -DXP_UNIX
mozilla-plugin.pc doesn't add -DXP_UNIX
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-28 00:34 EST by Braden McDaniel
Modified: 2009-03-02 02:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 516682 (view as bug list)
Environment:
Last Closed: 2009-03-02 02:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 480887 None None None Never

  None (edit)
Description Braden McDaniel 2009-02-28 00:34:32 EST
Description of problem:
NPP_GetMIMEDescription only gets declared (in npapi.h) if XP_UNIX is defined.  mozilla-plugin.pc doesn't appear to be defining that (or pulling in anything that does).

Version-Release number of selected component (if applicable):
1.9.1-0.8.beta2
Comment 1 Braden McDaniel 2009-02-28 02:24:54 EST
It looks like it needs to define OJI as well.
Comment 2 Martin Stransky 2009-03-01 12:34:42 EST
You have to include mozilla-config.h file...
Comment 3 Braden McDaniel 2009-03-01 13:44:01 EST
That shouldn't be required.  That has never been the use case in the past and it's not the use case for mozilla-js.pc.
Comment 4 Martin Stransky 2009-03-02 02:09:22 EST
Thanks for the upstream report, let's track it there.

Note You need to log in before you can comment on or make changes to this bug.