This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 48787 - Cannot mount root fs after upgrade to kernel-smp-2.2.19
Cannot mount root fs after upgrade to kernel-smp-2.2.19
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 15:52 EDT by jcmain
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 08:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jcmain 2001-07-11 15:52:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-22smp i686)

Description of problem:
After following the instructions on the RedHat web site to upgrade the
kernel and rebooting the machine to use the new kernel, I get the following
error:

...
... autorun DONE.
apm: BIOS not found.
request_module[block-major-8]: Root fs not mounted
VFS: Cannot open root device 08:09
Kernel panic: VFS: Unable to mount root fs on 08:09

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh kernel-utils-2.2.19-7.0.8.i386.rpm
2. rpm -ivh kernel-smp-2.2.19-7.0.8.i686.rpm (I also tried
kernel-smp-2.2.19-7.0.8.i386.rpm with the same end result)
3. vi /etc/lilo.conf :
      boot=/dev/sda
   map=/boot/map
   install=/boot/boot.b
   prompt
   timeout=50
   linear
   default=linux
   message=/boot/message

   image=/boot/vmlinuz-2.2.19-7.0.8smp
	label=linux
	read-only
	root=/dev/sda9

   image=/boot/vmlinuz-2.2.16-22smp
	label=linux-2.2.16
	initrd=/boot/initrd-2.2.16-22smp.img
	read-only
	root=/dev/sda9

   image=/boot/vmlinuz-2.2.16-22
	label=linux-up
	initrd=/boot/initrd-2.2.16-22.img
	read-only
	root=/dev/sda9
4. run lilo:
   Added linux *
   Added linux-2.2.16
   Added linux-up
5. Reboot 
	

Actual Results:  While shutting down, 2.1.16-22smp shows errors about
/dev/pts being in use and /home being busy, 3 times each. But, the shutdown
then proceeds as normal.

Upon boot up, everything looks normal until the following is displayed

... autorun DONE.
apm: BIOS not found.
request_module[block-major-8]: Root fs not mounted
VFS: Cannot open root device 08:09
Kernel panic: VFS: Unable to mount root fs on 08:09

Expected Results:  The 2.2.19smp kernel should have booted.

Additional info:
Comment 1 Arjan van de Ven 2001-07-11 16:07:58 EDT
2 steps missing:

mkinitrd /boot/initrd-2.2.19-7.0.8smp.img 2.2.19-7.0.8smp

and adding an initrd line with that filename to the kernel in lilo.conf 
(just copy the 2.2.16 one and change the filename)

Could you try that and report if that fixes it ?
Comment 2 jcmain 2001-07-12 08:07:47 EDT
Hello,

That did the trick. I don't know how I missed that (twice) in the instructions
at http://www.redhat.com/support/docs/howto/kernel-upgrade/kernel-upgrade.html.

I guess I wasn't worried about the initrd not being in lilo.conf, because I have
not used it (on my other machines) since I can remember - and I've been a linux
user since 0.99. 

Thanks for the quick response!
jcmain
Comment 3 Arjan van de Ven 2001-07-12 08:12:15 EDT
Well, you only need an initrd if your rootfs is SCSI and SCSI is a module, 
as it is in RHL 7.1.

Anyway, I'll close this bug as "NOTABUG" as the docs are right and
it works ;)

Note You need to log in before you can comment on or make changes to this bug.