Bug 487878 - Can't use domain names in SMB share
Can't use domain names in SMB share
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-28 12:38 EST by Emanuele Bellini
Modified: 2015-03-03 17:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 06:35:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This configuration doesn't work (26.86 KB, image/png)
2009-02-28 12:40 EST, Emanuele Bellini
no flags Details
This does work. (25.49 KB, image/png)
2009-02-28 12:41 EST, Emanuele Bellini
no flags Details

  None (edit)
Description Emanuele Bellini 2009-02-28 12:38:59 EST
Description of problem:
I have a Windows XP "server": in it I have some shares (a folder, a printer). When I try to connect with the window "Connect to a server..." from the Places menu (I have the Italian version of Gnome, I try to do my best!) I can use the IP address of the Windows PC to access the share, but not its name. Of course, I insert the domain name in the field.


Version-Release number of selected component (if applicable):
nautilus-2.24.2-2.fc10(i386)


How reproducible:
Always


Steps to Reproduce:
It's a very long story, if you need the steps let me know, I'll be pleased to help you.

  
Actual results:
I can connect only using the IP address.


Expected results:
I should connect using the name of the computer and the domain name.


Additional info:
It was also a Fedora 9 issue.
Comment 1 Emanuele Bellini 2009-02-28 12:40:04 EST
Created attachment 333614 [details]
This configuration doesn't work
Comment 2 Emanuele Bellini 2009-02-28 12:41:27 EST
Created attachment 333615 [details]
This does work.
Comment 3 Tomáš Bžatek 2009-03-02 08:42:09 EST
I have encountered this issue before but wasn't able to reproduce it in our lab. Any help leading to clear reproducer would be appreciated.

First: can the 'Desktop' hostname be resolved via standard host or dig commands?
Second: does 'smbclient //Desktop/backup -U Emanuele' work?
Alternatively, you can try running 'smbtree' and attach the output here.

For full debugging, set the env. variable GVFS_SMB_DEBUG=4 and manually spawn '/usr/libexec/gvfsd-smb server=Desktop share=backup user=Emanuele' (or try experimenting with that, removing user, anonymous setup etc.). That would mount the share so you can directly access it via Nautilus.
Comment 4 Emanuele Bellini 2009-03-02 15:57:56 EST
I'm a Linux newbie, so if type some commands in a wrong way, just say it.


1)No, they don't work.

$ host Desktop
Host Desktop not found: 3(NXDOMAIN)

$ dig Desktop

; <<>> DiG 9.5.1-P1-RedHat-9.5.1-1.P1.fc10 <<>> Desktop
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 53473
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;Desktop.			IN	A

;; Query time: 6246 msec
;; SERVER: 192.168.1.2#53(192.168.1.2)
;; WHEN: Mon Mar  2 21:48:41 2009
;; MSG SIZE  rcvd: 25


192.168.1.2 is my router.

2)No, it doesn't; it works only if I put the IP address instead of the "Desktop" name. That's not surprising.

3)The smbtree command doesn't return any results:

$ smbtree
Password: 
$ smbtree -D
Password: 
$ smbtree -b
Password: 

I haven't typed a password, of course. (What password have I to put right there? I tried to do it, it didn't work anyway)

3)The mount fails:

$ /usr/libexec/gvfsd-smb server=Desktop share=backup user=Emanuele
setting 'server' to 'Desktop'
setting 'share' to 'backup'
setting 'user' to 'Emanuele'
Added new job source 0x878a820 (GVfsBackendSmb)
Queued new job 0x878b020 (GVfsJobMount)
send_reply, failed: 1
Mount failed: Mount della condivisione Windows non riuscito


What I've done is that: I put up a simple Windows network of two computers, I specified only the domain name (which is WORKGROUP, the default one). They're linked with a LAN in the same net, of course.
Now I can browse the Windows network with XP in "My Network Places": I can see the list of the two computers (my notebook and my desktop). But not in Linux. In fact, in the "Places/Network" menu (in Fedora) I have a "Windows network" icon, if I double-click on it, it appears a message: "Impossible to mount; Failed to retrieve share list from server". It seems to be ano... The same bug!
Moreover I expect that with Nautilus I can open that folder, since with Windows I can do it just specifying the domain name, that hasn't been asked me.
Comment 5 Tomáš Bžatek 2009-03-03 07:59:59 EST
(In reply to comment #4)
> 2)No, it doesn't; it works only if I put the IP address instead of the
> "Desktop" name. That's not surprising.
That looks like a smbclient issue then, something we can't change from gvfs.

Additional check: please make sure to turn your firewal off.

> 3)The smbtree command doesn't return any results:
> 
> $ smbtree
> Password: 
> $ smbtree -D
> Password: 
> $ smbtree -b
> Password: 
> 
> I haven't typed a password, of course. (What password have I to put right
> there? I tried to do it, it didn't work anyway)
You shouldn't need password for that. Again, might be a firewalling issue.

> 3)The mount fails:
> 
> $ /usr/libexec/gvfsd-smb server=Desktop share=backup user=Emanuele
> setting 'server' to 'Desktop'
> setting 'share' to 'backup'
> setting 'user' to 'Emanuele'
> Added new job source 0x878a820 (GVfsBackendSmb)
> Queued new job 0x878b020 (GVfsJobMount)
> send_reply, failed: 1
> Mount failed: Mount della condivisione Windows non riuscito
If previous two commands failed, there's no point trying it this way again.

Can you also please attach your /etc/nsswitch.conf here?
Comment 6 Emanuele Bellini 2009-03-04 06:35:11 EST
Oops, I'm very sorry... I didn't know SMB browsing is disabled by default in the firewall (I couldn't remember how it works).
Forgive me.

Note You need to log in before you can comment on or make changes to this bug.