Bug 487893 - Severe memory leak with latest X server
Severe memory leak with latest X server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-28 18:38 EST by Adam Huffman
Modified: 2009-04-16 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 19:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screengrab of htop showing excessive memory usage (159.19 KB, image/png)
2009-02-28 18:41 EST, Adam Huffman
no flags Details
Xorg log file (61.39 KB, text/plain)
2009-02-28 18:43 EST, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2009-02-28 18:38:58 EST
Description of problem:
Just updated my laptop (Vaio SZ3, Intel 945 chipset) to kernel 2.6.29-0.159.rc6.git3.fc11.x86_64 and the new -intel package, having not been able to use a kernel newer than -119.  The system is very sluggish and it looks like it might be a leak in the Intel X driver or possibly some other part of X.

At the moment I don't have an xorg.conf.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.6.0-9.fc11.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Huffman 2009-02-28 18:41:40 EST
Created attachment 333622 [details]
Screengrab of htop showing excessive memory usage
Comment 2 Adam Huffman 2009-02-28 18:43:27 EST
Created attachment 333623 [details]
Xorg log file
Comment 3 Nathaniel McCallum 2009-03-06 15:20:06 EST
I too am seeing this problem.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

$ ps aux | grep Xorg | grep -v grep
root      2792 15.1 12.8 1619556 506500 tty1   Ss+  09:44  50:08 /usr/bin/Xorg :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-lgY7gS/database -nolisten tcp vt1

$ sudo lsof -p 2792 | wc -l
23595
Comment 4 Adam Williamson 2009-04-16 18:50:22 EDT
There've been quite a few kernel and intel updates since this bug was filed: are you still seeing this behaviour? Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Huffman 2009-04-16 19:20:24 EDT
Yes, it's fixed as far as I'm concerned.
Comment 6 Adam Williamson 2009-04-16 19:57:40 EDT
OK, closing as fixed. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.