This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 487923 - kxkb configuration: 'show country flag' checkbox is broken
kxkb configuration: 'show country flag' checkbox is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 08:57 EST by fr.prop
Modified: 2009-05-18 05:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 05:51:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fr.prop 2009-03-01 08:57:46 EST
Description of problem:
In KDE Keyboard Layout Switcher configuration, there is 'show country flag' checkbox, but checkin/unchecking it changes nothing.


Version-Release number of selected component (if applicable):


How reproducible:
allways

Steps to Reproduce:
1.create at least 2 keyboard layouts
2.check 'show country flag'
3.
  
Actual results:
nothing chages, grey box all the time

Expected results:
show flag when checked

Additional info:
Comment 1 Rex Dieter 2009-03-01 09:04:21 EST
Flags have been ommitted from packaging per fedora policy/guidelines:
http://fedoraproject.org/wiki/Languages#I_wish_to_use_my_country.27s_flag_to_refer_to_my_language...
Comment 2 fr.prop 2009-03-01 09:16:44 EST
In the policy, there is just "don't use flags",but what about KTorrent, it uses flags?

Anyway, please consider removing the chekbox completely.
Comment 3 Rex Dieter 2009-03-01 13:51:51 EST
Patches welcome.
Comment 4 Kevin Kofler 2009-03-01 13:56:57 EST
I think the checkbox should be hidden or disabled if and only if the flags are actually missing. It's possible to add them (in fact I should resurrect the kdebase-flags package which was once submitted for review to Livna, but whose submitter lost interest).
Comment 5 Kevin Kofler 2009-03-01 14:04:43 EST
(And in fact I still wish this asinine policy could be overturned. These flags are perfectly legal in the US where Fedora is hosted and in most of the rest of the world, why do we let one or two countries dictate what Fedora is allowed to ship? If we did that consistently, there would be a lot more stuff which would have to be removed than just flags.)
Comment 6 fr.prop 2009-03-03 13:32:56 EST
(In reply to comment #3)
> Patches welcome.

huh, I'm not programmer sorry :)

(In reply to comment #5)
> (And in fact I still wish this asinine policy could be overturned. These flags
> are perfectly legal in the US where Fedora is hosted and in most of the rest of
> the world, why do we let one or two countries dictate what Fedora is allowed to
> ship? If we did that consistently, there would be a lot more stuff which would
> have to be removed than just flags.)

Yes, I agree. First, I've thought, it's policy it's nonplus. But why is there that policy?

If some country / political group doesn't like some flags, I don't care I live in free world (at least I hope so).

and flags are changing sometimes? Yes they do, but why is this such big problem? If someone from that country will arrive to the political meeting, there will be table with his name, name of the country and with flag, so there is always some flag you can/should use.

so... Is there any way how to re-open discussion about this policy?
Comment 7 Rex Dieter 2009-03-03 13:43:01 EST
Spot told us awhile back that policy regarding this should be published and be made public real-soon-now.
Comment 8 Steven M. Parrish 2009-03-16 22:03:40 EDT
Since its not a bug, but a policy issue going to close this.  If the policy is ever changed feel free to reopen.
Comment 9 Rex Dieter 2009-03-16 22:29:09 EDT
Looks like a new policy is coming soon, and from my first glance, looks like we will afterall be able to package flags again.
Comment 10 Rex Dieter 2009-04-13 13:18:03 EDT
Ok, following the new policy, kdebase-workspace-flags (optional) subpkg now exists in kde-4.2.2 builds, currently in updates-testing.
Comment 11 Lukáš Tinkl 2009-05-18 05:51:49 EDT
Installing kdebase-runtime-flags solves this bug, closing

Note You need to log in before you can comment on or make changes to this bug.